View Issue Details

IDProjectCategoryView StatusLast Update
0009911Multi Theft Auto : San AndreasClientpublic2018-09-11 23:31
ReporterJayceonAssigned To 
PriorityhighSeveritycrashReproducibilityN/A
Status closedResolutionsuspended 
PlatformOSOS Version10
Product Version1.5.5 
Target VersionFixed in Version 
Summary0009911: Crash when plane explode
Description

The MTA Client crash when the nearby plane explode.
Tried with 4 people, all crashed.

Steps To Reproduce

Spawn a hydra, and explode yourself.

TagsNo tags attached.

Relationships

related to 0008926 closed Multi Theft Auto : San Andreas setElementHealth causing any error you can imagine 
related to 0008765 closed New issues Need help tracking down crashes. 
related to 0009701 closed New issues fixVehicle() in onClientVehicleCollision crashes client if vehicle is blown 

Activities

Dutchman101

2018-07-16 01:04

updater   ~~0026706

Cannot reproduce on r12430, please include more details, a crash log/dump.

Dutchman101

2018-07-16 02:23

updater   ~~0026707

Last edited: 2018-07-16 02:24

View 2 revisions

Pretty sure you're on about crash at offset 0x00168003, which is very rare. A particular server accounts for most crashes on this offset.
It's been present even back on 1.5.2, so no recent changes have caused it.

I suspect it's a bad custom model (for example, on the hydra) or other rare trickery that caused it. ( https://imgur.com/a/IguDkjo - please get back to us only when you managed to isolate what was wrong with your server's resources)

Jayceon

2018-07-16 18:51

viewer   ~~0026716

The server has no mods.

Version = 1.5.5-release-12411.0.000 (updated to r12430 but no changes)
Time = Mon Jul 16 17:03:45 2018
Module = C:\Program Files (x86)\Rockstar Games\GTA San Andreas\proxy_sa.exe
Code = 0xC0000005
Offset = 0x00168003

Dutchman101

2018-07-16 18:55

updater   ~~0026718

Show us a video with the reproduction (steps taken, eventually recording the crash) and please make a list of recent resource changes to your server

Jayceon

2018-07-16 19:19

viewer   ~~0026720

Video: https://youtu.be/kGe1zACoyFU
What do you mean "list of recent resource changes to your server"?

Dutchman101

2018-07-16 19:23

updater   ~~0026722

thanks for the video, what I mean with that is because it's interference/trouble by something on your server (to be frank, we shouldn't be on tracker for this but on server support) and not MTA's fault, we need to find out about the causal factor; when did it start happening, I guess a few days ago as you're reporting it now? Please list all resource changes (full description) between the date this crash wasn't occuring yet and the date it appeared, and upload these recently changed resources completely to http://upload.mtasa.com.

Jayceon

2018-07-16 20:02

viewer   ~~0026728

I found the problem in onVehicleDamage event.

Jayceon

2018-07-16 20:12

viewer   ~~0026729

Or run this code (still crash):

addEventHandler("onVehicleDamage", getRootElement(),
function (loss)
print("vehicle damaged")
end
)

myonlake

2018-07-21 17:16

updater   ~~0026761

Unable to reproduce in Multi Theft Auto v1.5.5-release-12430.

Jayceon

2018-07-22 13:09

viewer   ~~0026800

Client: Multi Theft Auto v1.5.5-release-12430
Server: multitheftauto_linux_x64-1.5.5-rc-13687

When I remove onVehicleDamage event from server-side the crash disappear.
But when I add the event and plane explode near to me, the crash appear.

The onClientVehicleDamage event works good.

Jayceon

2018-07-22 18:18

viewer   ~~0026836

Update: When I put onClientVehicleDamage and call the source element still crash. :/

ccw

2018-07-22 21:09

administrator   ~~0026843

Please make a resource which reproduces the problem

Jayceon

2018-07-23 12:20

viewer   ~~0026852

Okay, soo... I found the final problem, the onVehicleDamage is works good, but the client sided onClientVehicleDamage not.
I put the code below this message and I fly to the wall by a plane or exploded it by RPG/Rhino the client crashes.
The crash disappear when I remove onClientVehicleDamage event :)

StifflersMom

2018-07-23 16:48

updater   ~~0026853

I can confirm this with the following one line runcode based on Jayceon's demo:

crun addEventHandler("onClientVehicleDamage", getRootElement(), function() setElementHealth(source,1) end )
Take a hydra and blow / crash it.
Seems to work only with planes and vortex.

Sounds like a similar problem with peds ( #8926 )

Dump attached.

myonlake

2018-07-23 16:53

updater   ~~0026854

Confirmed. The first and the second one match at least partially according to the stacktrace.

Issue History

Date Modified Username Field Change