View Issue Details

IDProjectCategoryView StatusLast Update
0009901Multi Theft Auto : San AndreasGUIpublic2018-07-13 10:32
ReporterCodyJAssigned Toccw 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version1.5.5 
Target Version1.5.6Fixed in Version1.5.6 
Summary0009901: [Bug] dxDrawRectangle darker on certain systems.
Description

dxDrawRectangle draws alot darker on certain systems then it's suppose to.

function dxDrawRectangle(x,y,w,h,c,g)
dxDrawImage(x,y,w,h,rectangle, 0, 0, 0,c, true)
end

Was able to resolve the issue by replacing it with a 1x1 white image however I shouldn't have to do so if a built in function exists.

Steps To Reproduce

draw a dxRectangle on certain systems, hard to really reproduce because it only happens on some systems.

Additional Information

Only happens on some systems.

https://cdn.discordapp.com/attachments/459784850942066690/465250593322041364/mta-screen_2018-07-07_16-19-37.png // How it's suppose to draw.

https://cdn.discordapp.com/attachments/459784850942066690/465255338959044618/mta-screen_2018-07-08_04-38-26.png // How it draws on the problematic systems (There's nothing I could really find that'd cause it)

TagsNo tags attached.

Activities

ccw

2018-07-08 08:35

administrator   ~~0026650

Has MTA\cgui\images\rect_edge.png been modified on the problematic systems?

Inspirator

2018-07-08 15:52

viewer   ~~0026652

@ccw, thanks! that was the problem. I fixed it now. It was replaced with a black image when i replaced some images to change look of the GUI. It's supposed to be white.
Here's the original https://i.imgur.com/QPiXUyp.png

CodyJ

2018-07-08 16:04

viewer   ~~0026653

Checking with the client(s) who had this problem now.

CodyJ

2018-07-08 17:02

viewer   ~~0026654

Alright well; I suppose that's the issue.

ccw

2018-07-13 06:03

administrator   ~~0026688

rect_edge.png has been moved in to the source code because it is vital for the correct operation of dxDrawRectangle
https://github.com/multitheftauto/mtasa-blue/commit/4e57a8b1977a5a500172f86c3202297f9c11eb7b

Issue History

Date Modified Username Field Change