View Issue Details

IDProjectCategoryView StatusLast Update
0009895Multi Theft Auto : San AndreasMulti Theft Auto : San Andreaspublic2018-07-06 12:04
ReporterSaml1erAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0009895: MTA crashing when using knife or some other melee weapons after updating to r12343
Description

Today i updated my MTA to nightly r12343 and suddenly my game always crashes when i try to use a knife and some other melee weapons.

Steps To Reproduce

-Open map editor
-give a knife
-press mouse button
-crash

Crash dumps attached.
MTA Diag shows nothing special, just my modified grass 3D models that are in my folder since 2012.

Additional Information

Version = 1.5.5-release-12343.0.000
Time = Fri Jul 6 02:49:10 2018
Module = D:\Program Files (x86)\MTA San Andreas 1.5\mta\game_sa.dll
Code = 0xC0000005
Offset = 0x000036CE

EAX=00000000 EBX=05D037E8 ECX=00000000 EDX=6830C46C ESI=00B51AA0
EDI=42FC3F38 EBP=0177FB98 ESP=0177FB94 EIP=682736CE FLG=00010246
CS=0023 DS=002B SS=002B ES=002B FS=0053 GS=002B

TagsNo tags attached.

Activities

Saml1er

2018-07-06 07:45

updater   ~~0026625

Thanks for the report. The commit has been reverted, the fix still needs to be applied later. I'll try to reproduce with the steps you gave after fixing the "fix".

einheit-101

2018-07-06 11:49

reporter   ~~0026628

Was this the CAnimBlendStaticAssociation::Init crash?
At first I expected this crash was caused by engineReplaceAnimation, but then I saw it crashed without doing anything.

Dutchman101

2018-07-06 11:54

updater   ~~0026630

Last edited: 2018-07-06 11:56

View 2 revisions

it wasn't einheit, the crash was introduced by the intended fix for the "CAnimBlendStaticAssociation::Init" crash though.
pAnimHierarchy was returning NULL randomly because there was a hardcoded "MAX_ANIMATIONS" limit somewhere, unaccounted for in the changes, that would return NULL when exceeded.

Fixed in r12349 (https://github.com/multitheftauto/mtasa-blue/commit/1d37c73735c9be10d08ad312b8c9fb18142b41ce is actually a revert, altho the commit message doesn't state it)

Issue History

Date Modified Username Field Change