View Issue Details

IDProjectCategoryView StatusLast Update
0009889Multi Theft Auto : San AndreasClientpublic2018-07-14 01:18
ReporterarranTunaAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.5.6 
Target Version1.5.6Fixed in Version1.5.6 
Summary0009889: Modified binds are broken in newest MTA (again)
Description

Various players have been complaining that binds which they changed the key of are not working and I'm getting it too.

I have a script which does:

addCommandHandler("toggleadminpanel", toggleAP)
bindKey("p", "down", "toggleadminpanel")

I changed this key to "o" a long time ago and now after updating, pressing o does nothing.

Can't bind it because it says already bound:

  • 'o' 'down' key already bound to command 'toggleadminpanel'

It won't even let me unbind it:

  • Failed to unbind 'o' 'down' from command 'toggleadminpanel'

v1.5.5-release-12240

I'm guessing this is what has caused this problem: https://github.com/multitheftauto/mtasa-blue/commit/c5c6b3cfaaa7480cc6feb2f20a54717fc18e26ab

Seems that doing "unbind o" fixed it as can now do "bind o toggleadminpanel".

Steps To Reproduce

Unable to give steps to reproduce because only old binds are bugged, maybe using old version of MTA to create a bind would create a bugged bind to test with.

Here is one that's bugged and how it's stored in my coreconfig.xml:

<bind key="e" state="down" command="Reload weapon" resource="reload" default="r"></bind>

It's not showing up in options, binds.

Found a way to reproduce using new version only:

crun addCommandHandler("blah", function() outputChatBox("blah") end)
crun bindKey("p", "down", "blah")
Press esc, options, binds, find runcode and change the p bind to o
Reconnect.
crun addCommandHandler("blah", function() outputChatBox("blah") end)
crun bindKey("p", "down", "blah")
Press o, nothing, press p, nothing
The bind is in coreconfig as: <bind key="o" state="down" command="blah" resource="runcode" default="p"></bind>
But it does not work.

TagsNo tags attached.

Relationships

related to 0009178 confirmed unbindKey not working properly 

Activities

arranTuna

2018-06-29 20:32

manager   ~~0026583

Tested v1.5.5-release-12224 and it works fine so must be that commit I linked to.

arranTuna

2018-06-29 22:33

manager   ~~0026584

Tested v1.5.5-release-12250 and the revert fixed it.

arranTuna

2018-07-10 21:46

manager   ~~0026684

This has started happening again with Multi Theft Auto v1.5.5-release-12356 because of: https://github.com/multitheftauto/mtasa-blue/commit/bbd05a541dbca0275c34be5dedddaf776017e382

Bonus1702

2018-07-10 22:17

reporter   ~~0026685

Working on it, seems like I did a mistake while testing.
Binding it 2x (after reconnect) and it works.
So should be easy to fix.
Sry ...

Bonus1702

2018-07-10 22:47

reporter   ~~0026686

PR:
https://github.com/multitheftauto/mtasa-blue/pull/237
Tested already for 10 minutes, will continue testing it for again 10 minutes to make sure everything works :D

Issue History

Date Modified Username Field Change