View Issue Details

IDProjectCategoryView StatusLast Update
0009874New issuesAdministration Requestspublic2018-07-21 23:02
ReportermarcinegAssigned Tomyonlake 
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionno change required 
Summary0009874: onVehicleExit/onClientVehicleExit doesn't work properly
Description

When we are in the vehicle and it will be destroyed, the event will not be called.

Steps To Reproduce

Give a vehicle and remove it, for example, with an admin panel.

TagsNo tags attached.

Activities

myonlake

2018-07-06 11:50

updater   ~~0026629

Use https://wiki.multitheftauto.com/wiki/OnElementDestroy and https://wiki.multitheftauto.com/wiki/OnClientElementDestroy

In my opinion destroying a vehicle element is not equal to someone exiting it. They are very different behaviors (or add a parameter bDestroyed).

Dutchman101

2018-07-06 12:03

updater   ~~0026631

Exactly.. once a vehicle is destroyed, there's nothing left to exit.
If you want to suggest a new parameter "bDestroyed" such as myonlake offered, then please create a new request issue.
Right now, this seems like intended behaviour.

Issue History

Date Modified Username Field Change