View Issue Details

IDProjectCategoryView StatusLast Update
0009853New issuesClientpublic2018-09-30 13:48
ReporterxnikoxdAssigned To 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionno change required 
Summary0009853: setPedControlState(ped, "crouch") needs a perfect frame false state on clients with higher than 40fps to actually crouch
Description

As I said, when trying to make a ped crouch using setPedControlState(ped, "crouch", true) the ped starts doing the animation of crouching, then stops and gets up after some frames. I tried some things and I found that after 35-40fps, even using a Timer of 50ms the ped will still get up (not like when you press C that even with 100fps your player drops to the ground, crouches, then after that he starts getting up).

The only way to make the ped crouch on higher FPS than 40 is using onClientRender, and then stopping it that way, wich is really problematic. If it cant be fixed because limitations with the engine, then I will submit a request about a function like setPedCrouch or something.

I only tried this test with peds, because I saw that with the localPlayer it actually crouchs completely.

Steps To Reproduce

This is the function I used for testing the timers, use /agacharse 50 and it will run up to 1500, but i highly recommend just to get it to 500ms because even with 25fps you can't get crouched on 200ms+

https://pastebin.com/RxX6vb3j

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change