View Issue Details

IDProjectCategoryView StatusLast Update
0009847New issuesClientpublic2018-09-30 13:46
ReporterseelrdAssigned To 
PriorityhighSeveritymajorReproducibilityrandom
Status closedResolutionno change required 
Summary0009847: Players lose connection while downloading from HTTP server
Description

Hello,

Random players get "connection lost" message during downloading our gamemode from our HTTP server.
Once, we've solved the issue at the player by installing a network speed limiter application where we limited the bandwidth/speed used for HTTP downloading, so the player didn't lose the connection with the MTA server.

It is a serious problem for us, as some of our players (mentioned by many) need to restart the download several times to be able to join our server. Maybe it is because our HTTP server is quite fast so it uses all the player's network connection.

Thank you!

TagsNo tags attached.

Activities

Dutchman101

2018-04-23 20:33

updater   ~~0026509

What are the values in your mtaserver.conf for the following settings;

<httpmaxconnectionsperclient>

<httpdosthreshold>

Also read the notes for them. It's more than likely misconfigured (less than optimal.. either for your typical player's net or the used HTTP server) so it's advised to play around with the values a bit to see if you can reduce the time-outs this way. If it's not, then it's simply a bad HTTP server.

seelrd

2018-04-23 20:41

viewer   ~~0026510

The internal MTA HTTP server is disabled, so I don't think these change anything as we use two nginx servers for serving HTTP files.

Also, I think, a misconfigured HTTP server shouldn't make MTA drop the connection. (Players do not get kicked because they can't download the files, they lose connection to the MTA server, not to the HTTP.)

Dutchman101

2018-04-23 20:48

updater   ~~0026511

Last edited: 2018-04-23 20:53

View 2 revisions

seelrd, the setting "<httpmaxconnectionsperclient>" also mentions "Depending on the type of http server" in the notes.. there's more than one type (the internal HTTP server) applicable to this line. The client requests a connection with the HTTP server, and the server's config is respected while establishing it.

Also you said "a misconfigured HTTP server shouldn't make MTA drop the connection", well it does, when a download timeout is reached, the client drops the connection. This is when progress has stalled (with 0 bytes received over a lengthy timeframe) without HTTP fail acknownledgement sent by the webserver. It is designed to do so..

Issue History

Date Modified Username Field Change