View Issue Details

IDProjectCategoryView StatusLast Update
0009836New issuesScriptingpublic2018-04-07 21:50
ReporterJeViCoAssigned Toccw 
PrioritynormalSeverityblockReproducibilityunable to reproduce
Status closedResolutionunable to reproduce 
Summary0009836: onClientRender + conditions
Description

When i use onClientRender + code like this:

if variable == true then
-- some action
end
dxDraw...
dxDraw...
-- Doesn't work

dxDraw functions will not work. Theese will work if i swap conditions with dxDraw function:

dxDraw...
dxDraw...
if variable == true then
-- some action
end

-- works

It's so annoying especially you have to render dynamic variables because they are nil when script starts. No info in debugscript 3. Same with community. Nobody knows what the problem

TagsNo tags attached.

Activities

JeViCo

2018-04-07 14:37

viewer   ~~0026499

-- some action - here i output some text in chat and i can see it in both situations

myonlake

2018-04-07 16:19

updater   ~~0026500

Unable to reproduce.

Please link your forum topic here so I can review your code and point out your problem.

Inspirator

2018-04-07 16:26

viewer   ~~0026501

Check your code, you probably have a return statement within that block.

JeViCo

2018-04-07 19:10

viewer   ~~0026503

link: https://forum.mtasa.com/topic/103780-rendering-problemdx-window/

ccw

2018-04-07 20:06

administrator   ~~0026504

Last edited: 2018-04-07 20:07

View 4 revisions

Your code from the link:
if condition then
....if condition then
....end
....dxDraw..
....dxDraw..
end

Issue History

Date Modified Username Field Change