View Issue Details

IDProjectCategoryView StatusLast Update
0009697New issuesScriptingpublic2017-08-03 21:03
ReporterGrafuAssigned To 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Summary0009697: onClientVehicleDamage does not work for remotely controlled vehicles
Description

onClientVehicleDamage does not get triggered for vehicles that are controlled by remote players.

Steps To Reproduce

function onClientVehicleDamage(killer)
outputChatBox(tostring(killer and getElementType(killer) == "vehicle" and getPlayerName(getVehicleController(killer)) or nil))
end
addEventHandler("onClientVehicleDamage", root, onClientVehicleDamage)

  1. Run the script
  2. Get in a car
  3. Get a remote player in another car
  4. Hit each other

You will see the remote player name outputting what means the event gets triggered only for your car.
It should also trigger for the remote player's car.
(to add: if a local player vehicle collides an empty vehicle, the chance is very low that onClientVehicleDamage will get triggered for the empty vehicle, but still higher than a remotely controller vehicle (which is 0% so far)).

TagsNo tags attached.

Relationships

duplicate of 0008558 new onClientVehicleDamage isn't called when remote players damage the car with melee weapons 

Activities

Grafu

2017-08-03 19:39

viewer   ~~0026130

Even doesn't get triggered if a remote player punches the car.

Grafu

2017-08-03 20:05

viewer   ~~0026131

^* Even doesn't get triggered if a local player punches a remotely controller car.

Issue History

Date Modified Username Field Change