View Issue Details

IDProjectCategoryView StatusLast Update
0009582New issuesScriptingpublic2018-07-24 03:25
ReporteriBlack.NexTAssigned Toqaisjp 
PrioritylowSeverityfeatureReproducibilityalways
Status closedResolutionwon't fix 
Summary0009582: isVehicleOnGround always returns false on Airplanes.
Description

It always returns false on Airplanes like (AT-400).

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 1

2017-03-29 20:08: iBlack.NexT (EUR 1)
Users sponsoring this issue (Total Sponsorship = EUR 1)

Relationships

related to 0008672 closed Multi Theft Auto : San Andreas isVehicleOnGround returns false on some vehicles upside down 
related to 0007880 closed Multi Theft Auto : San Andreas isVehicleOnGround always returns false for Monsters 

Activities

einheit-101

2017-03-29 23:51

reporter   ~~0025787

Related with https://bugs.mtasa.com/view.php?id=7880

Another bug report about it: https://bugs.mtasa.com/view.php?id=8672

isVehicleOnGround is known to have bugs and i recommend simply not to use it.

Inspirator

2017-04-02 16:57

viewer   ~~0025793

Use getGroundPosition instead and compare the distance with your vehicle/airplane

myonlake

2018-07-24 03:18

updater   ~~0026863

Unable to reproduce on server nor client-side in Multi Theft Auto v1.5.5-release-13771.

Fix would've occurred here: https://github.com/multitheftauto/mtasa-blue/blob/d7c9b06ac6bf4660c86006bc3a40f38d09bbfb30/Client/mods/deathmatch/logic/CClientVehicle.cpp#L3454

Issue History

Date Modified Username Field Change