View Issue Details

IDProjectCategoryView StatusLast Update
0009569New issuesClientpublic2017-03-21 10:59
Reportersolovey255Assigned ToJusonex 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Summary0009569: loadBrowserURL() returns "true" if loaded page not exists
Description

local loaded = loadBrowserURL(browser, "http://mta/resource/not_exists.html";)

(loaded = "true")

At the same time game shows "404 - not found" at top-left corner.

Steps To Reproduce

local loaded = loadBrowserURL(browser, "http://mta/resource/not_exists.html";)

TagsNo tags attached.

Activities

Jusonex

2017-03-21 10:59

administrator   ~~0025737

That's the intended behavior as loadBrowserURL loads the page asynchronously.
If you want to check for errors, please use https://wiki.multitheftauto.com/wiki/OnClientBrowserLoadingFailed and https://wiki.multitheftauto.com/wiki/OnClientBrowserDocumentReady instead.

Issue History

Date Modified Username Field Change