View Issue Details

IDProjectCategoryView StatusLast Update
0009551New issuesGeneralpublic2017-03-13 17:36
ReporterWAssigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Summary0009551: There is no way to provide monetary support for the project.
Description

With the removal of 'heroes' donations there is currently no way to support the project with funds.

While I agree that accepting paypal donations may be tricky, there should be another way.

I suggest going the way many open source projects choose: offering a distinct, 'plus', 'pro' or 'commercial' server license with monthly subscription. This version should not differ from normal version, maybe allowing access to global player count in lua or identifying itself as 'pro' version in sver.

A server maintainer should be able to switch to a 'plus' version when he'll want to support the project, and switch back without issues to normal version when he won't like to do that anymore.

This way, at least server owners will have a way to support the project. Otherwise, maybe advertising the project on Patreon or simillar service?

TagsNo tags attached.

Activities

AlexTMjugador

2017-03-12 16:37

viewer   ~~0025703

I have just visited https://mtasa.com/donate/ and it looks normal: both donators toplist and donate button seem to function as they should.

The issue you saw might be caused by the webmasters doing some kind of unannounced manteinance, or by a problem on the server, but I'm speaking from ignorance. It could also be a problem at your end, too. Anyway, I don't think that MTA would stop accepting donations without explaining the reasons in a forum post.

arranTuna

2017-03-13 17:36

manager   ~~0025710

Actually it was impossible to donate for a while, but now it's available again.

Issue History

Date Modified Username Field Change