View Issue Details

IDProjectCategoryView StatusLast Update
0009286Multi Theft Auto : San AndreasCEFpublic2016-10-20 21:24
ReporterukeecockAssigned ToJusonex 
PrioritylowSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product Version1.5.2 
Target Version1.5.3Fixed in Version1.5.3 
Summary0009286: CEF animations are totally lacking performance for some users
Description

This problem does not apply to all users. CSS and JS animations both are laggy. Even with a basic CSS keyframes animation. E.g with the following code http://pastebin.com/4yizUFr1 users notice some delaying and overall lagging animations. More complex animations are easier to be noticed. This problem seems not to be because of hardware. I am using Web Animations API (native) to make JS animations, which lag as bad as CSS ones.

Quote from Jusonex:
"The problem is that CEF doesn't use hardware implementation at the moment.
There are a few options I will enable soon to hopefully improve the performance a bit, but as long as the CEF authors don't implement proper hardware acceleration, GPU-intensive tasks like animations will remain laggy."

I mean yeah, but even the basic animations, come on.
As a side note: these lags are not present in the same CEF version of Spotify's CEF client.

-- All tests on latest version of MTA

Steps To Reproduce

This is a hard one. For now I have debugged animations to lag only for users that have over server FPS limit. I.e server's FPS limit is 53, I enable FPS meter from CEF dev tools. http://puu.sh/pLqha/bd1fb9ee0f.png FPS meter shows over the server FPS limit (53) for some users, and users that don't have lag don't go over 53.1 FPS. Changing FPS limit doesn't make the problem better or worse. Most guys who have the issue, have 512MB max usable browser memory.

Users that don't have lag have this shown in the FPS meter: http://puu.sh/pLpKA/aef113b95a.png

Additional Information

Sorry if I left something unclear or didn't describe the problem well enough. This is mostly due to it doesn't happen to me but half of the users.

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 10

2016-07-02 00:52: Bonsai11 (EUR 10)
Users sponsoring this issue (Total Sponsorship = EUR 10)

Activities

ccw

2016-06-30 19:47

administrator   ~~0024863

What do you mean by lag? Slow animations?

ukeecock

2016-06-30 19:57

viewer   ~~0024864

Animations are slow and being delayed, like running on 30 FPS.

ccw

2016-06-30 21:03

administrator   ~~0024865

The CEF frame rate limit is copied from the server FPS Limit when the browser window is created. So it's interesting that the CEF frame rate is showing as higher for some players.

Do these players have something in common, like OS / Graphics card / windowed mode / AA setting etc.. ?

ukeecock

2016-06-30 22:25

viewer   ~~0024866

Windows version varies from 7 to 10. Windowed mode/fullscreen and AA setting doesn't help the lag. And graphics card not really, they vary from GTX970 to laptop gpus. Network speed nope. But browser max usable memory seems to be 512MB for all of them.

ukeecock

2016-07-04 19:14

viewer   ~~0024899

On Chrome if you enable Weak MemoryCache in flags, you get 512MB maximum usable GPU memory. Also do you have any clue why some have red text on the FPS meter and others have blue?

I had one player to run MTA with my MTA settings, which didn't help at all, so you can close out that one. Turning Vsync off in GPU settings didn't help either.

Unable to test if it's GPU specific problem, haven't found two guys with same GPUs.

Jusonex

2016-08-31 19:17

administrator   ~~0025116

Could you please test again using the latest 1.6 nightly?
https://nightly.mtasa.com/?mtasa-1.6-full_unstable-latest

ukeecock

2016-09-03 09:48

viewer   ~~0025127

Great, it's working! Is there any possibility to get it included it in 1.5.3?

Jusonex

2016-09-03 12:21

administrator   ~~0025128

1.5.3 will be based upon the 1.6 branch

Bonsai11

2016-09-17 22:11

viewer   ~~0025216

Hey,

since this issue seems to be fixed now and I sponsored it, how does the payment work?

PS: Any idea when approx. 1.5.3 might be released?

Bonsai

Jusonex

2016-09-17 22:18

administrator   ~~0025217

https://www.multitheftauto.com/donate/

PS: Any idea when approx. 1.5.3 might be released?
Very soon

Issue History

Date Modified Username Field Change