View Issue Details

IDProjectCategoryView StatusLast Update
0008978Multi Theft Auto : San AndreasClientpublic2017-03-18 11:02
ReporterALBANDERAssigned ToTalidan 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.5.3Fixed in VersionNo Target Version 
Summary0008978: M4 bug
Description

Video for bug : https://youtu.be/LzMBa9U6Tbw

How to fix it ?

  • Quick Stand Glitch Disabled
TagsNo tags attached.

Activities

ALBANDER

2015-08-05 00:38

viewer   ~~0023797

Last edited: 2015-08-08 14:46

View 2 revisions

it can be occur with Deagle , shotgun and snipers Weapons Too.

qaisjp

2015-08-05 00:40

administrator   ~~0023798

Last edited: 2015-08-05 00:42

View 2 revisions

it seems like a general issue with weapons?

just to confirm, the person that the first player is shooting at seems to be just running, but in reality he is shooting back whilst moving?

edit: nevermind, they are different people, not different perspectives

I don't quite understand what the issue is here...

ALBANDER

2015-08-05 00:45

viewer   ~~0023799

Last edited: 2015-08-05 19:02

View 6 revisions

1 - it seems like a general issue with weapons?

Answer : Yes (it occur only if fast move glitch enabled.)

2- just to confirm, the person that the first player is shooting at seems to be just running, but in reality he is shooting back whilst moving?

Answer : yes , he is shooting while he moving

EDIT :

I don't quite understand what the issue is here..

Answer : Watch video from 5 seconds and you will understand

or click here : https://youtu.be/LzMBa9U6Tbw?t=5s

I don't know what is bug name , I can't called bug with name ,

but i'm asking it can be fixed or not ?

qaisjp

2015-08-05 00:47

administrator   ~~0023800

I still don't understand

ALBANDER

2015-08-05 00:49

viewer   ~~0023801

Last edited: 2015-08-05 00:57

View 4 revisions

I don't know what is bug name , I can't called bug with name ,

but i'm asking it can be fixed or not ?

EDIT : Wait Please, now my friend record video to show you it can be occur with deagle weapon too.

EDIT #2 : Change Summary to : "Unknown Bug with Weapons"

ccw

2015-08-05 01:25

administrator   ~~0023802

The bug is strafing + shooting locally, but crouch-straifing + shooting remotely?

ALBANDER

2015-08-05 01:41

viewer   ~~0023803

remotely ?

The bug it is occur by real players , not by remote peds to fire.

ccw

2015-08-05 01:55

administrator   ~~0023804

Video 0:00 to 0:06
Red guy (local player) strafing while firing over fence - Kills enemy

Video 0:07 to 0:10
Blue guy (remote player) crouch-strafing while firing into fence - Kills enemy

ALBANDER

2015-08-05 02:00

viewer   ~~0023805

The bug it is recorded and occur Here : mtasa://37.59.197.160:22003

there is 7 players in server while bug occur.

There is no remotely Peds to make bug.

ccw

2015-08-05 02:17

administrator   ~~0023806

remote player

ALBANDER

2015-08-05 02:28

viewer   ~~0023808

Wait Please , My Friend will record another video and using Deagle !

arranTuna

2015-08-05 12:02

manager   ~~0023816

So you're saying that your server enables glitches and then you complain when there's a glitch..?

qaisjp

2015-08-05 12:21

administrator   ~~0023818

Yes Arran, a different glitch

ALBANDER

2015-08-05 19:03

viewer   ~~0023828

Arran , this bug occur only if "fast move" glitch enabled.

IIYAMA12

2015-08-06 21:22

viewer   ~~0023849

This (new) glitch is going on for a while.
"fast move" is a useless glitch, (almost) nobody is using it. I am not sure why people want to enable it, but it is included in some cbug resources.

The only thing that might be handy is by adding some extra info about it on wiki.(to prevent multiply threads about this...) It is in my opinion a bit overdoing to fix a glitch caused by another (useless)glitch, which is disabled by default.

ccw

2015-08-06 22:03

administrator   ~~0023850

IIYAMA12, can you explain what the bug is?

IIYAMA12

2015-08-07 00:03

viewer   ~~0023851

Well it is very simple. When that glitch is enabled.
Randomly players get synced like this, while shooting their gun: https://dl.dropboxusercontent.com/u/63149063/M4%20Bug%20-%20YouTube%202015-08-06%2023-42-53.png His legs are getting stuck in the ground and his movement are the same as he is standing. When he stops his shooting animation the player will be "reset".
This image(captured) comes from the video(https://youtu.be/LzMBa9U6Tbw) that Albander added on 2015-08-05 00:00.

The local player will not see this animation himself, he will be seeing the default animation. But the remote players will see it as the image and video.

Video
A player starts watching over a remote player on 0:07 t/m 0:10. (this is where the 'glitch' is visible)
It is only a petty he didn't film the remote player(as a localPlayer) while he was shooting.

qaisjp

2015-08-07 01:16

administrator   ~~0023856

Last edited: 2015-08-07 01:17

View 3 revisions

It seems like different shots because that ped is shaded black and appeared to be crouching. Thank you very much IIYAMA12 for the explanation.

Should this be fixed considering that it is an artifact of an enabled glitch?

ALBANDER

2015-08-07 07:25

viewer   ~~0023864

Last edited: 2016-06-22 19:33

View 12 revisions

Just a reminder , The Bug Can be occur too with Deagle , Shotgun and sniper Weapons.

This bug will be fixed in 2016-05-16 ?

Why this bug don't confirmed ?

Remember , this bug don't occur until enable "Fast move" Glitch.

NEW VIDEO : https://youtu.be/UOFOp4wleDA

How make the bug occured : first step ' press button " C " to crouch down

second step " press button " C " again to stand up " and press button " A " togehter with button C , fastly and after that keep your finger on " A " button

the bug occur when you have a "Deagle - m4 - shotgun .... etc"

Lex128

2016-06-20 18:24

reporter   ~~0024831

Yes, confirmed and reproduced
May be need lite syncing crouch state

Talidan

2016-07-04 16:39

administrator   ~~0024898

Last edited: 2016-07-04 16:41

View 2 revisions

These are both the 'fastmove' bug, initiated in different ways. I don't know yet if they can be seperated.

The fastmove bug was intended to prevent players from 'moving fast' as soon as they stood up and entering aim. When I initially fixed it, it was to prevent people sprinting with heavy weapons whilst aiming. In other words, it was initiated by using the 'sprint' key to stand up from crouching.

This is the same bug, only instead of using the 'sprint' key to stand up, you're using the traditional 'crouch'key. The result is you aren't running with the gun, but instead sliding slightly faster than walking.

Fundamentally it's the same bug. However, from the video it seems one causes desync in crouch states while the other doesn't.

Talidan

2016-07-04 19:39

administrator   ~~0024900

MTA can only tell when a player is fully stood up, and doesn't know when a player starts the process of standing up. Hence, there's a noticable delay in 'standing up' sync because the remote players only get told to start the stand-up process once the local player has fully stood up.

The desync is caused by taking advantage of this delay. Whilst standing up, if a player presses left or right, remotely they will begin doing a crouchroll (because remotely, we dont know they're in the process of standing up). The aiming then takes over as the primary task, but in a bugged-crouched state.

A crude solution to this is to reset the remote player's task every time he stands up whilst aiming and moving. I don't know the overall consequences of doing something as drastic as this to fix the desync. However, I've replicated the code in a resource which you can download from here: https://community.mtasa.com/index.php?p=resources&s=details&id=13368

I haven't noticed any side-effects of doing this, but I don't want to integrate it build it into MTA for such a niche usage. With the use of the above resource, I'm marking this issue as solved.

ALBANDER

2016-08-02 17:38

viewer   ~~0025009

Last edited: 2017-03-18 11:02

View 2 revisions

but why it fixed as resource ?

if will add a new Argument in "SetGlitchEnabled" will be better

Here : https://wiki.multitheftauto.com/wiki/SetGlitchEnabled

but the glitch name is unknown.... !!!!

Issue History

Date Modified Username Field Change