View Issue Details

IDProjectCategoryView StatusLast Update
0008895New issuesClientpublic2019-06-18 02:43
ReporterWAssigned Toqaisjp 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionno change required 
Summary0008895: 1.5 does not work under Wine/Linux
Description

On Wine, MTA 1.5 crashes everytime with:

Version = 1.5-release-7307.0.000
Time = Wed Jun 24 18:00:34 2015
Module = C:\Program Files (x86)\Rockstar Games\GTA San Andreas\proxy_sa.exe
Code = 0xE06D7363
Offset = 0xFFC00000

Automated of installation of vcrun2013 within MTA installer failed: http://lbiegaj.netshock.pl/_/screenshot-24-06-15-706885021-219062674.png

I've reinstalled it manually with winetricks vcrun2013.

Tested on two different computers with 64-bit Ubuntu. MTA 1.4 works flawlessly on them.

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 65

2015-06-26 23:35: xProKillerx (EUR 15)
2015-10-27 18:22: DLmass (EUR 50)
Users sponsoring this issue (Total Sponsorship = EUR 65)

Relationships

related to 0008993 closedJusonex [Request] Compiling 1.5 without CEF for Wine users. 

Activities

arranTuna

2015-06-24 19:19

manager   ~~0023415

Last edited: 2019-06-18 02:43

View 3 revisions

"As Wine is bad in terms of the anticheat anyway, Wine support may be dropped soon entirely."

Considering how many problems Wine has and considering how few people must use it, IMO it's not worth the effort.

Gallardo9944

2015-06-28 07:44

viewer   ~~0023461

You can make it work by manipulating some dlls and other things, but CEF will not work by any means (it will not be visible). This is related to Chromium issue under Wine which is probably going to stay like that (according to winedb). I suggest switching to VMware.

TomasitoCaram

2015-08-13 12:25

viewer   ~~0023915

@Gallardo, could you explain please? :D

DLmass

2015-10-27 18:21

viewer   ~~0024119

I get the same error and I find it kinda annoying that I really need to run windows to be able to play it. So yeah someone please port MTA to osx so we can expand our player base even more!

==============================================
Version = 1.5-release-7562.0.000
Time = Tue Oct 27 18:19:04 2015
Module = C:\Program Files\Rockstar Games\GTA San Andreas\gta_sa.exe
Code = 0xE06D7363
Offset = 0xFFC00000

EAX=7B818511 EBX=0C2F9510 ECX=00000000 EDX=00000000 ESI=0204CF40
EDI=0177EDF4 EBP=0177ED98 ESP=0177ED24 EIP=7B82AA17 FLG=00000206
CS=001B DS=0023 SS=0023 ES=0023 FS=1007 GS=000F

Gallardo9944

2015-11-13 14:12

viewer   ~~0024151

Whoever wants to run mta 1.5 under Wine, I use these library replacements:

amstream (external)
atl110 (external,internal)
atl120 (external,internal)
browseui (external,internal)
crypt32 (external,internal)
gdiplus (external)
hhctrl.ocx (external,internal)
hlink (external,internal)
iernonce (external,internal)
iexplore.exe (external,internal)
inetcpl.cpl (external,internal)
inseng (external)
itircl (external,internal)
itss (external,internal)
jscript (external,internal)
jscript.dll (external,internal)
mlang (external,internal)
mshtml (external,internal)
msimtf (external,internal)
msvcp110 (external,internal)
msvcp120 (external,internal)
msvcr110 (external,internal)
riched20 (external,internal)
secur32 (external,internal)
shdoclc (external,internal)
shdocvw (external,internal)
shlwapi (external,internal)
url (external,internal)
urlmon (external,internal)
usp10 (external,internal)
uxtheme (external,internal)
vcomp110 (external,internal)
vcomp120 (external,internal)
xmllite (external,internal)
msvcr120 (external,internal)

Wine version is 1.7.53 (32 bit version, POL).
The game works, not sure which libraries are important and which are not. CEF seems to work (?), haven't tested it properly yet. Overall performance is lower than Wine 1.4.1 but it's still playable.

W

2015-11-13 17:17

viewer   ~~0024152

Last edited: 2015-11-13 17:42

View 3 revisions

Great news Gallardo, I'm already hating vmware performance (it was so much better on wine), unfortunately I still can't run 1.5 with these settings.

I can confirm that vcrun2013 installs without errors after upgrading WINE to newest 1.7.x.

I'll fiddle with libraries a litle bit though, and maybe it will finally work ;).

edit: after switching windows version to XP, everything just works, including CEF! :D

AlexTMjugador

2015-11-13 18:29

viewer   ~~0024153

I know that this is a little off-topic, but if someone managed to get MTA: SA 1.5 working under Linux, it would be worthwhile to update this Wiki page: https://wiki.multitheftauto.com/wiki/Client_on_Linux_Manual . That way Linux users will be able to play MTA: SA 1.5 with ease.

W

2015-11-13 20:19

viewer   ~~0024154

Sure thing Alex, I'll rewrite this manual this weekend. I'm currently trying to establish minimal stable configuration.

Gallardo9944

2015-11-22 20:40

viewer   ~~0024180

Last edited: 2015-11-22 20:50

View 4 revisions

MTA launches with black screen with Wine version starting at 1.7.54. Consider using STAGING versions of Wine, 1.7.55-staging from POL seems to work well. It provides better performance than 1.7.53 as for me. It's likely that pulseaudio layer is the reason because alsa-to-pulse had to provide double sampling causing double impact on CPU with audio.

Forgot to mention it requires XP as Windows version, right. Should have said it earlier.

nokizorque

2015-12-17 09:25

viewer   ~~0024243

Has anyone tried playing 1.5 using PlayOnLinux?

Gallardo9944

2015-12-19 15:18

viewer   ~~0024249

I do, noklzorque. Use the tutorials given above.

rafalh

2016-02-21 17:07

viewer   ~~0024426

Lastest MTA 1.5.2 works fine in Wine 1.9.4 after installing fonts in winetricks. Ubuntu 14.04

TheNormalnij

2016-06-12 23:21

viewer   ~~0024780

Ubuntu 16.04 x64, wine-1.9.12 (only win32 prefix and Windows verrsion: "Windows 7") + fonts
Running good, but without browser.

qaisjp

2016-06-13 02:59

administrator   ~~0024781

I'm going to close this since this is an issue directly related to a crash. I'm glad that you guys have found a solution for the issue.

If anyone needs fonts, they can be found here: https://www.dropbox.com/sh/vt10ov64hfna7ol/AABQz_OvqMsZD-t3KSx8ZUIGa?dl=0

These were the files that we needed to get MTA running on OS X. There's also a winmm.dll file in there but I do not know if it is relevant anymore.

Issue History

Date Modified Username Field Change