View Issue Details

IDProjectCategoryView StatusLast Update
0008750Source patches[All Projects] Generalpublic2015-02-14 00:01
ReporterBpb_XommkoAssigned Toccw 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.5 
Summary0008750: Guest account data is saved to database
Description

Guest account data is saved to internal.db with userid=0, though description says that it should persist until player leaves the server.

Additional Information

https://wiki.multitheftauto.com/wiki/SetAccountData

TagsNo tags attached.

Activities

Bpb_Xommko

2015-02-08 13:00

viewer   ~~0022979

This is related to accounts moving to internal.db in r1637, before this revision they were working as intended, but since r1637 they are broken and were never fixed.

Bpb_Xommko

2015-02-09 13:03

viewer   ~~0022983

Last edited: 2015-02-09 13:05

View 3 revisions

Made a patch, now guest accounts have separate account data in-memory. Also fixed a bug that copyAccountData only copied one key from account, but not all. But please check before applying.

https://gist.github.com/anonymous/f2a07562a9fda6a733e3

ccw

2015-02-14 00:01

administrator   ~~0022998

Thanks for the patch. Applied (with some formatting tweaks) in https://code.google.com/p/mtasa-blue/source/detail?r=7079

Issue History

Date Modified Username Field Change