View Issue Details

IDProjectCategoryView StatusLast Update
0008672Multi Theft Auto : San AndreasClientpublic2018-09-16 16:42
Reportercastillo14Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0008672: isVehicleOnGround returns false on some vehicles upside down
Description

What the title says.

Screenshot: http://i.imgur.com/LNu2nE6.jpg

TagsNo tags attached.

Relationships

related to 0009582 closedqaisjp New issues isVehicleOnGround always returns false on Airplanes. 

Activities

Grafu

2014-12-09 07:30

viewer   ~~0022648

Some vehicles return false even being on wheels.

castillo14

2014-12-09 09:36

viewer   ~~0022649

Do you know a work-around for this?

Gallardo9944

2014-12-09 13:06

viewer   ~~0022652

You can use vehicle bounding box as the size of the vehicle for that. Use IsLineOfSightClear and remove checks for vehicles and players. It's also possible to add 1-2 meters to the box to see if the vehicle is actually on wheels or anywhere else.

einheit-101

2014-12-23 12:45

reporter   ~~0022720

It just happened here with a Rhino. It returned true then i jumped over a cliff. While in air it returned false but after landing on the wheels it still returned false. I fixed it by jumping again. After the second landing it returned true. Never seen this issue before but that is the answer why one of my scripts randomly stops working sometimes.

qaisjp

2014-12-26 18:37

administrator   ~~0022724

In this particular case I would expect this. i think this should be a wontfix.
Just do a processLineOfSight with the target z being decremented by one unit.

einheit-101

2014-12-26 20:23

reporter   ~~0022726

If this won`t get a fix, "isVehicleOnGround" is useless and should be deprecated imo.

arranTuna

2015-07-05 20:17

manager   ~~0023552

Confirmed with a Securicar:

-- Enter Securicar
crun setElementRotation(localPlayer.vehicle, 0, 180, 0) setElementPosition(localPlayer.vehicle, -2247, -713, 68)
crun isVehicleOnGround(localPlayer.vehicle)

Multi Theft Auto v1.5-release-7323

It applies to some vehicles, but not others. Possibly because the tyres are far away from the ground and that's what it's using the check if on ground?

Issue History

Date Modified Username Field Change