View Issue Details

IDProjectCategoryView StatusLast Update
0008590Multi Theft Auto : San AndreasClientpublic2017-05-01 16:10
ReporterStifflersMomAssigned ToZ_ReC 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.5.5Fixed in Version1.5.5 
Summary0008590: createEffect with some effects places it's sfx sounds to position 0,0,0
Description

Summary says all, last checked with release-6893

Steps To Reproduce

Runcode:
crun createEffect("fire_large",-688.13000, 931.41705, 23.0,0,0,0)
after that, set your player position to 0,0,10
You can hear the fire sound.

TagsNo tags attached.

Relationships

has duplicate 0008569 closed Sound of the effect is not updated after position change 

Activities

lopezloo

2014-10-23 21:11

developer   ~~0022209

Last edited: 2014-10-23 21:15

View 2 revisions

Oh, that's why I thought sfx position isn't updating after position change - https://bugs.multitheftauto.com/view.php?id=8569

It's weird because I can hear sound for short time at properly position but after that pos changes to 0, 0, 0.

StifflersMom

2016-01-25 10:08

updater   ~~0024352

Retested with 1.5.2 ... still present :(

Z_ReC

2017-04-29 21:37

reporter   ~~0025868

Last edited: 2017-04-30 02:11

View 3 revisions

The same happens with the effect of motolovs, vehicles, etc.

Possible solution: https://github.com/multitheftauto/mtasa-blue/pull/124

lopezloo

2017-04-30 23:56

developer   ~~0025882

I was thinking how this actually works for effects created by GTA. It doesn't. I'm surprised nobody noticed this before lol.

run me.position = Vector3(2106.764, 1673.380, 10.820)
There are fountains which should produce sound but they don't :(

StifflersMom

2017-05-01 11:02

updater   ~~0025885

r11320 fixes also the fountains sounds at 2106.764, 1673.380, 10.820 :)

Foe me, it's fixed.

einheit-101

2017-05-01 16:10

reporter   ~~0025890

I did not found that bug because I did not even know effects should have sounds.
I never heard one effect having sound and therefore I use custom sounds for fire etc.

And tbh maybe it's better to add an argument "sound" true/false if scripters don't want sound.

Issue History

Date Modified Username Field Change