View Issue Details

IDProjectCategoryView StatusLast Update
0008522New issuesVehiclespublic2018-09-30 14:27
ReporterAlexTMjugadorAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformMTA 1.4OSWindows 8.1OS Version
Summary0008522: Motorbikes spin out of control when warping them to places which are streamed out
Description

I discovered this bug some time ago when I was doing a script to teleport motorbikes inside interiors. I used a Lua workaround with timers and the setElementFrozen function to prevent this, but I think it would be nice to fix this for consistency (this only happens with bikes).

What this 'bug' basically does is spin out motorbikes with great force in an uncontrollable manner, like the summary says. Using setVehicleVelocity and setVehicleTurnVelocity have no effect at all and motorbike's occupants fall out of the bike if they can.

Steps To Reproduce

Create a script which teleports a motorbike occupied by you into a interior (or far away exterior position) which is streamed out. To see this bug more clearly make sure the bike is teleported to a position which is nearby the ground.

Additional Information

I think that this bug is caused due to the "detachables positions" of the bike not being set correctly (they use different memory adresses). According to http://www.gtamodding.com/wiki/Memory_Addresses_(SA) , "we need to recalculate and set their locations if we warp a car from one location to another. Otherwise the car spins uncontrollably". These are the memory offsets, if you find them useful:

+1532 = BikeDetachPosAdr(0)
+1632 = BikeDetachPosAdr(1)
+1676 = BikeDetachPosAdr(2)
+1720 = BikeDetachPosAdr(3)
+1764 = BikeDetachPosAdr(4)
+1828 = CarDetachPosAdr(0)
+1872 = CarDetachPosAdr(1)
+1916 = CarDetachPosAdr(2)
+1960 = CarDetachPosAdr(3)

TagsNo tags attached.

Relationships

related to 0005318 resolvedccw Multi Theft Auto : San Andreas setElementPosition for vehicles on a non streamed in position will make the vehicle spin very quickly 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change