View Issue Details

IDProjectCategoryView StatusLast Update
0008319New issuesClientpublic2018-09-30 14:27
ReporterDutchman101Assigned To 
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionunable to reproduce 
Summary0008319: Exiting vehicle at speed will stuck you for a moment
Description

If you leave an vehicle that has reached some speed as a passenger, randomly you will not directly exit it, but as he slows down, randomly pop out of the vehicle.

This is an very old bug. Actually, if you trigger leaving the car, you will ''disattach'' in logic: radio will turn off if it was on, awaiting when, randomly it will exit you; you could also driveby (realdriveby lean weapon out) and it will instantly exit you, instead of waiting the time after this bug randomly stucks you for undefined time (mostly when the driver slows down, or brings the vehicle to a stop)

TagsNo tags attached.

Relationships

related to 0007438 closedqaisjp Multi Theft Auto : San Andreas Exit from vehicle at high speed causes desync for 5 sec 

Activities

Dutchman101

2014-07-10 23:36

updater   ~~0021315

To add, when the vehicle slows down significantly (instead of stopping) the chance to get out increases to where it does randomly, like if a corner is being taken.

and when, if you are stucked you lean out for driveby it will instantly fix as warping you out directly as explained, but notable is that then it could warp you onto the vehicles' roof when you manage to get out that way, this might indicate where the cause can be.

Eren97

2014-07-15 12:41

viewer   ~~0021350

I guess this is because of the gap in SA between stepping out and jumping out.
In Singleplayer, you can only step out under a certain speed as well as only jump out over a certain speed.
Between that, nothing happens iirc.
So my guess is MTA waits for you to reach 1 of those 'events'

qaisjp

2014-07-15 13:27

administrator   ~~0021351

In my opinion it's not much of a glitch but an interesting way to get around this is to provide Lua functions to control it... setVehicleExitSpeeds(step, jump) (and the according get variable, of course)...

Dutchman101

2015-03-08 07:55

updater   ~~0023081

And also when it looks like GTA already assumes you're out when still occupant you can't perform any action that you could when you weren't in an car anymore and it still returns being occupant of the vehicle; So maybe it's an desync between GTA and MTA where MTA doesn't recognize that GTA already had let the player finish exiting the vehicle?

But then still no idea how it's related to velocity to pop out and exit finally.

Issue History

Date Modified Username Field Change