View Issue Details

IDProjectCategoryView StatusLast Update
0008132New issuesClientpublic2018-09-29 16:49
ReportersocialzAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionsuspended 
PlatformPCOSWindowsOS Version7
Summary0008132: Projectile target only allows player element (and a projectile?)
Description

Apparently the createProjectile function only allows a player target (if using heat seeking missiles). This should allow a lot more than that, because I have scripts that sometimes have empty vehicles and I want to destroy these empty vehicles.

Perhaps allow heat seeking in a form of "targeting" system, that it will target an element regardless of heat, since it seems like that is the issue right now, nevertheless pedestrians cannot be targeted, so it seems to be a wider issue (perhaps?).

Test script: http://pastebin.mtasa.com/173727451

Located at the navy base in San Fierro by default. Look at the debug while at it.

Oh, and look at the behavior of a rocket when passing in a projectile target. It seems to target the projectile, but seems to not list up on debug - why?

Steps To Reproduce
  1. Create a projectile
  2. Target at anything but player (even vehicles with engine on)
  3. Rocket doesn't respond to anything... unless the target is a projectile
Additional Information

http://pastebin.mtasa.com/173727451

TagsNo tags attached.

Activities

socialz

2014-03-31 19:12

viewer   ~~0020518

Last edited: 2014-03-31 19:13

View 2 revisions

I decided to add pickups and markers as well, even though those aren't actually any "living" elements.

einheit-101

2014-03-31 20:36

reporter   ~~0020522

I can confirm that Players and projectiles as target work. Btw i think projectiles are the most bugged elements of MTA right now...

socialz

2014-03-31 22:18

viewer   ~~0020527

Cazomino explained on IRC that projectiles are rather hard to make working ("impossible") on other element types as there are no syncers. The networking will become difficult in terms of fair projectile collision. But if a developer has a solution to this, it would be nice.

lopezloo

2014-03-31 22:28

developer   ~~0020528

Projectile issue number 123151.

Issue History

Date Modified Username Field Change