View Issue Details

IDProjectCategoryView StatusLast Update
0008012Multi Theft Auto : San Andreaspublic2018-09-05 22:17
ReporterdrifterCZAssigned To 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0008012: Many collisionless objects - no way to fix
Description

I'm experiencing big problem with many objects on my server

I create objects using createObject function. I use custom col, dff and txd for some objects but these works ok.

There are some typical objects which very often don't have collisions and I have no idea how to fix it.

It's not script problem, when I go join other server, it still occurs

Steps To Reproduce

No idea, but it happens very often

Additional Information

Typicly about 30% players have the 'problematic' objects collisionless, other players can play without any problems. When this starts to happen, it keeps bugging until you restart MTA.

TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 80

2014-11-09 22:34: BrianAndrews (EUR 30)
2016-11-26 22:16: einheit-101 (EUR 20)
2018-04-06 18:38: arranTuna (EUR 30)
Users sponsoring this issue (Total Sponsorship = EUR 80)

Relationships

has duplicate 0009444 closed New issues Bug after replace collision. 
has duplicate 0009850 closed New issues Dissapearing of collision for id 5808 
related to 0008202 closed New issues Object ID 1894 is loosing its collisions after a long client uptime 

Activities

kakaksk

2014-01-27 06:42

viewer   ~~0020082

It's because they get unloaded due to a really big amount of streamed-in objects. Might be a memory issue.

ccw

2014-01-27 09:12

administrator   ~~0020083

Can you make a resource to reproduce the problem?

arranTuna

2014-01-27 11:37

manager   ~~0020084

Maybe related but the grass in the park at Palisades (San Fierro) became collisionless on CIT possibly after the addition of CITy which replaces some wire objects with custom walls.

drifterCZ

2014-01-27 15:44

viewer   ~~0020085

yes arran that object is often bugged too on my server. And I also replace wires (from LV)

drifterCZ

2014-02-06 01:59

viewer   ~~0020167

OK I made a lot of research and I'm able to reproduce this situation for one object model.

  1. Use following link http://drifterCZ.mtasa.cz/bugs/collisions.rar (2 separate resources)
  2. '/start objects' - now you should be spawned.
  3. '/start textures' - replaces the texture, model and collision of carshade object (placed nearby)
  4. '/stop textures' - do not use /restart, collisions don't get bugged when using restart for some reason
  5. '/start textures' - from now the pipe object is collisionless, as long as you restart MTA

Notice: If you are standing on the pipe during stoping the texture script (when collisions are still working ok), you may notice the object is doing some kind of 'reload' althrought the scripts doesn't have anything to do with this object.

Please test it and confirm

Inspirator

2014-02-06 13:39

viewer   ~~0020168

Above method confirmed. And I have a feeling this doesn't only happen to the pipe objects but other objects too. I have experienced this bug many times before especially in[DD] maps. It must be related to textures being reloaded.

arranTuna

2014-02-06 15:32

manager   ~~0020169

Tested and confirmed, it seems like replacing the collisions on a certain object ID can cause another objects collision to disappear.

drifterCZ

2014-02-06 16:21

viewer   ~~0020170

Last edited: 2014-02-06 16:23

View 2 revisions

Now I noticed it happens only when replacing COL and DFF. If only COL is replaced, it doesnt get bugged. Maybe related to restoring model

ccw

2014-02-10 06:33

administrator   ~~0020175

Thanks for the example resource.
Try replacing in this order: COL, TXD, DFF

arranTuna

2014-03-13 14:15

manager   ~~0020379

Tested it and the bug cannot be reproduced in the order COL, TXD, DFF but it can be with TXD, COL, DFF.

drifterCZ

2014-04-27 20:24

viewer   ~~0020791

Tried to change the order in my resource, no change... I cannot send example resource because its connected with my other scripts, but its always reproducable on my server, can say details if u are interested

BrianAndrews

2014-05-15 10:46

viewer   ~~0020892

I have access to some resources in CIT and I have some experience in 3D modeling. I tried to fix the buggy SF park by applying a custom .col file modeled on the part of land that lost its collisions. The park was fixed after applying this custom col file but the cliff near the park became collisionless.
Random buildings started losing collisions in other places of map as well, but we removed them with removeWorldModel so they won't cause any issues.

BrianAndrews

2014-10-15 11:39

viewer   ~~0022177

Last edited: 2014-10-15 13:08

View 4 revisions

I found another object that after being replaced with a custom col, loses it's collisions.

https://www.dropbox.com/s/qy8drs7d2wtipc8/TestResource.rar?dl=0

The resource above changes model ID 5323 (wires object) and applies custom files in the order suggested by ccw. Though, after starting the resource and restarting MTA, object ID 5403 (http://puu.sh/cd04E/20206a9729.jpg) loses its collisions.

I added a fix for collisions to object ID 5403 and later whole Glen Park area became collisionless. If I disable engineLoadCOL and engineReplaceCOL functions, said bugs do not appear.

Necktrox

2014-10-23 00:34

developer   ~~0022207

I could observe that collision bug on a DD (race mod) server and we solved it (95-99% success) by resetting the dff/txd/col changes in each resource @ onClientResourceStop, where models got replaced. Maybe that helps.

BrianAndrews

2014-10-23 00:49

viewer   ~~0022208

Last edited: 2014-11-09 17:01

View 2 revisions

I personally keep replacing cols on bugged objects:

If an object becomes collisionless, I take the nearest one and extend its collisions in a 3D editor, then map an object over it in order to cover a bugged area. It's a long work, yes, but it's the only way to cover the buggy areas, since directly apply a custom .col on bugged model causes another bug in an infinite chain.

EDIT: after a little talk, I realized that collisions loss bug is most likely to happen in crowded servers. I made a test in a server with an average of 500 players online and world objects lose collisions, even after reconnecting to said server. I switched to the dev server (which is obviously empty but with the same running scripts as main one) and same objects had collisions this time.

My speculation is: is it possible that great part of memory is used to stream in other players and the remaining one isn't enough to stream in correct collisions?

arranTuna

2014-11-09 23:03

manager   ~~0022302

Last edited: 2014-11-09 23:52

View 3 revisions

I wonder if the Eir branch has already fixed this problem, as it already contains a plethora of txd/dff/col changes. If someone can reproduce this problem without the need for many players, then they might want to try an eir build to see if it makes any difference.

Edit: Managed to reproduce it. When I first spawned it was fine, then I left the area and came back and then it was collisionless. Need to try Eir.

Edit: Didn't get the bug on the Eir build.

einheit-101

2014-11-10 12:54

reporter   ~~0022304

Where did you even get an Eir build as long as the last build has been released 7 months ago and doesnt even work nowadays?

arranTuna

2014-11-10 13:43

manager   ~~0022305

I used the 6 month old build on nightly.mtasa.com and it worked for me. Did crash once though.

BrianAndrews

2015-12-22 10:39

viewer   ~~0024254

We experience this bug mainly when streaming out mapped objects:

I was standing on a solid mapped objects while deleting another one next to it. As soon as I deleted the object, the one I was standing on became collisionless.

Bug occurs after MTA has been running for few hours (based on my experience).

-GTX

2016-09-25 15:21

reporter   ~~0025242

As this hasn't been fixed yet, I'll need to do a workaround. Does someone have ALL IDs on which collision bugs?

OnlineCheater

2016-09-25 16:10

viewer   ~~0025243

Last edited: 2016-09-25 16:14

View 3 revisions

Found a way to fix it:

Problem: loading a custom model / custom texture -> some objects had their cols bugged (no way to fix it with setElementCollisionsEnabled or engineRestoreCOL or any other function)

Solution: Just export the dff files from the bugged objects (from your gt3.img) and then open them in 3Ds, export the col files with kams tools and use them with this script:

local cols = {"ad_jump.col", "garys_luv_ramp.col", "landjump.col", "landjump2.col", "waterjump1.col", "waterjumpx2.col"}
local ids = {3080, 1894, 1633, 1634, 1632, 1655}
addEventHandler("onClientResourceStart", root,
function()
for i = 1, #cols do
col = engineLoadCOL(cols[i])
engineReplaceCOL(col, ids[i])
for j, v in ipairs(getElementsByType("object")) do
if j == ids[i] then
setElementCollisionsEnabled(v, true)
end
end
end
end)

Edit: I need to know others ids, please post them here if you find more.

I've tested it; worked with success!
Hopefully MTA devs could take a look at this bug for next versions so we don't have to use this alternative anymore then..

arranTuna

2016-09-25 20:58

manager   ~~0025245

@-GTX it depends on what objects you applied mods to. If I remember correctly the first object that got bugged for us was the ground at the park in North SF. Then there's boxes and staircases that have become bugged. It seems to happen a lot to specific objects. Then sometimes if there's a lot of modified objects in the area, random objects become collision-less and that'd fixed on reconnect. The old eir branch fixed this bug somehow.

Necktrox

2016-09-25 21:06

developer   ~~0025246

Last edited: 2016-09-25 21:07

View 2 revisions

At this point I would like to repeat myself that you can prevent this collision bug from happening on race maps, which use custom objects with collisions.

On my server I could eliminate this issue by adding a simple script to each map with custom objects. That script unloads every model when the map stops - and it works.

http://pastebin.com/jLfMC0Up

-GTX

2016-10-28 14:19

reporter   ~~0025353

@arranTuna I don't think so. I have maps on my server that replace small objects and never the object that loses its collision (I checked). Objects that lose collision are mostly waterjumps and you have to quit MTA to restore them.

@Necktrox Your solution does not work. I unload everything when map stops (Multigamemode).

This still occurs on latest 1.5.3 by the way, now even more often than before. OnlineCheater's solution works with success rate of 100% but this bug really needs a fix as more and more objects become collision-less and we cannot add them all to that table.

arranTuna

2016-10-28 18:54

manager   ~~0025354

AFAIK that hack fix of applying the default GTA collisions manually won't help because it simply causes another random object to become collision-less.

einheit-101

2016-11-26 22:16

reporter   ~~0025440

Last edited: 2016-12-03 16:31

View 2 revisions

Now this bug terrorizes my server. I got multiple reports of players falling through the ground. I guess this is now bug #1 for me.

€DIT::: This bug is happening randomly for some players. I have no issue (except 1 known object that has no col), while my assistant cant walk on that wooden stair in the picture below:
http://imgur.com/a/3bTLo

arranTuna

2018-02-18 18:23

manager   ~~0026435

As this is in my expert opinion the most annoying bug in MTA, it should be on 1.6 target version.

BrianAndrews

2018-02-18 19:29

viewer   ~~0026436

https://www.dropbox.com/s/6irtfv63xivw3qt/TestResourceBug2.rar?dl=0

I've made another test resource, this time it replaces a common building in Idlewood, the Pizza Shop. After starting the resource, do

/crun setElementPosition(localPlayer, 1849.2609, -1402.8617, 13.3906)

You will fall through the road. The 2 objects aren't even related as they are far away. (World model ID of the bugged road: 5498)

einheit-101

2018-02-18 22:51

reporter   ~~0026437

I can confirm. This test resource reproduces the bug perfectly fine. And it doesnt even help to let the road stream out and in again, the collision is broken forever.

arranTuna

2018-02-25 12:30

manager   ~~0026445

Using testresourcebug2 I was wondering if there was pattern between model ID that is applied to and model ID that gets bugged, turns out there is.

That resource applies a mod to 5418 and then 5498 becomes collisionless. That's +80 model ID difference.

So then I tried applying the same mod to 5419 and then... 5499 became collisionless. That's + 80 model ID difference.

Then I tried 1257 to see if 1337 was bugged. It wasn't, this could be because 1257 is a destroyable bus stop, so I will check a solid object.

Tried a mod on 10308 and 10388 (both were buildings) didn't become bugged.

Tried 5400 and 5480 became bugged, so 3 times out of 5 it was +80 model ID that became bugged.

codylewiz

2018-02-25 15:32

viewer   ~~0026446

Replacing 'Objects' such as trees, gates, fences, anything that is dynamic or instanced multiple times in the .ipl list causes broken collisions from my experimentation's. However if that pizza shop breaks it then maybe there's something more to it.

qaisjp

2018-09-05 22:17

administrator   ~~0026953

Moved to https://bugs.mtasa.com/view.php?id=8012

Issue History

Date Modified Username Field Change