View Issue Details

IDProjectCategoryView StatusLast Update
0007773Multi Theft Auto : ResourcesClientpublic2013-08-19 11:59
ReporterkakakskAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version8
Product Version 
Target Version1.5Fixed in Version1.5 
Summary0007773: setLowLODElement doesn't work as intended.
Description

The attached low lod element is always visible, while it should only be only visible when the normal model isn't.

Steps To Reproduce

I dont have an example right now, but creating 2 elements - 1 normal, 1 lod and setting them with the function should be ok. Be sure they arent on each other, so you will be able to clearly see that the function doesnt work. Some people sees 2 cloned elements on each other and gets confused about being it 1.

TagsNo tags attached.

Activities

ccw

2013-08-16 15:11

administrator   ~~0019155

Can't reproduce. Example Lua please.

kakaksk

2013-08-16 16:46

viewer   ~~0019156

sorry, i have no access to my pc to get the ids, but the reproduction with carrier body is good enough. You will see low lod element parts growing out of the normal model while standing near the normal moden and the lod element shouldnt be visible.

kakaksk

2013-08-16 16:48

viewer   ~~0019157

or try doing it in map editor and choosing "use low lod elements" in the settings. The carrier body can be found by typing "carrier" in the object browser

ccw

2013-08-17 01:26

administrator   ~~0019159

This is what I tried and saw no problems:

x,y,z = 0,0,0
objNormal = createObject ( 10771, x,y,z,0,0,0 )
objLowLOD = createObject ( 10901, x,y,z,0,0,0,true )
setLowLODElement ( objNormal, objLowLOD )
engineSetModelLODDistance ( 10771, 300 )

ccw

2013-08-17 02:07

administrator   ~~0019160

Ok, found and fixed problem with LODs in the mapeditor

kakaksk

2013-08-18 14:47

viewer   ~~0019167

I have tried reproducing the bug today and it seems that the function was already working. The mystery is that I havent seen any notes on google code about fixing this since the time I reproduced the bug. My code was

normal = createObject ( 10771, -3183.91772, 265.60144, 0.67451, 0, 0, 0, false)
lodModel = createObject ( 10901, -3183.91772, 265.60144, 0.67451, 0, 0, 0, true)
setLowLODElement ( normal, lodModel )

Well, I guess I was only disturbing for no reason. I am sorry ^-^

arranTuna

2013-08-18 14:54

developer   ~~0019168

According to the fix the issue was to do with using cloneElement

http://code.google.com/p/mtasa-resources/source/detail?r=949

I didn't initially intend to use cloneElement but with all the different properties I figured it'd be the simplest way to make a LOD.

Issue History

Date Modified Username Field Change