View Issue Details

IDProjectCategoryView StatusLast Update
0007610Source patchesMulti Theft Auto : San Andreaspublic2013-05-10 11:45
Reportersbx320Assigned Toccw 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.3Fixed in Version1.3.3 
Summary0007610: Patch for 0007609 (getVehicleSirens on a sandking (495) crashes the server immediately)
Description

This patch fixes #0007609 which was caused by using an unitialized variable (tSirenBeaconInfo.m_ucSirenCount) as limit in a for loop and therefore exceeding the bounds of an array, by clearing the sirens in the constructor of CVehicle. This patch also fixes a bug which would occur upon calling getVehicleSirens after removeVehicleSirens, which would result in weird return values (Default Args of all parameters in the table).

Patch: http://sbx320.net/mta/Issue_7609_CVehicle.cpp.patch

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change