View Issue Details

IDProjectCategoryView StatusLast Update
0007493Source patchesMulti Theft Auto : San Andreaspublic2015-02-24 07:46
ReporterKenixAssigned ToKenix 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.2Fixed in Version1.3.2 
Summary0007493: Patch for #0007378: outputChatBox: visibleTo is not checked for errors
Description

#0007378

Additional Information

Code for testing:

--1) Bad element pointer

local aPlayers = {}

addCommandHandler( 'add',
function( pPlayer )
table.insert( aPlayers, pPlayer )
end
)

addCommandHandler( 'reproduce',
function()
outputChatBox( 'Test', aPlayers[ 1 ] )
end
)

--[[
For example:
1) Player 1 joined to the server, write a /add command and then left the server.
2) Console/Player write command /reproduce
]]

--2) Arguments

outputChatBox( nil ) -- false, write error in debug script about argument type
outputChatBox( 'Test', nil, 255, 0, 0, false ) -- true, red text color.
outputChatBox( '#FF0000 Test #00FF00 This!', nil, 255, 255, 255, true ) -- true, color coded text.
outputChatBox( 'Test', nil, nil, nil, 255, true ) -- true, not all arguments for color, color doesn't changed.
outputChatBox( 'Test', nil, 255, 0, 0, nil ) -- true, text with red color.

TagsNo tags attached.

Relationships

related to 0007378 resolvedKenix Multi Theft Auto : San Andreas outputChatBox: visibleTo is not checked for errors 

Activities

Kenix

2013-02-01 18:34

updater   ~~0018088

Last edited: 2013-02-01 23:13

For Cazomino: If element is invalid this doesn't crashed server because i check element via lua_toelement and it's working.

Xeee

2015-02-24 07:46

viewer   ~~0023039

tostring()

Issue History

Date Modified Username Field Change