View Issue Details

IDProjectCategoryView StatusLast Update
0007421Multi Theft Auto : San AndreasClientpublic2018-09-16 16:37
ReporterKernellAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionsuspended 
Platformx64OSWindows 7OS Version6.1.7600
Product Version 
Target VersionFixed in Version 
Summary0007421: setVehicleComponentRotation has no effect for some vehicle nodes
Description

setVehicleComponentRotation has no effect if node controlled by GTA:SA.
For example - misc_a in ZR-350 (animated headlights), misc_b in Firetruck with ladder, wheels (wheel_rf_dummy, wheel_lf_dummy and etc).

TagsNo tags attached.

Relationships

related to 0008719 resolvedccw setVehicleComponentRotation in 1.4.0.7000 

Activities

Brzysiek

2014-05-04 14:14

viewer   ~~0020837

bump

Cazomino05

2014-06-13 03:07

reporter   ~~0021005

I do know about this, it's likely because they are being read from somewhere else

my guess is the model info array.

einheit-101

2015-01-03 08:28

reporter   ~~0022786

Last edited: 2015-01-04 14:16

View 2 revisions

I need this, too. If its even fixable. I cant rotate any custom dummys/objects in a dff. The ability to rotate them is hardcoded, i found 9 dummys that work and those misc_a, b, c, d and e work on some vehicles.
That means, the statements in this wiki entry:
https://wiki.multitheftauto.com/wiki/Vehicle_component_manipulation
Are not correct, in fact, component manipulation is VERY limited.

€DIT: Important! This limitation seems to apply ONLY for dummies. I can move AND rotate any 3D object in a vehicle.dff without problems. Dummies are not that important if you can use objects instead so the priority of this issue should be low imho.

myonlake

2018-09-05 02:41

updater   ~~0026926

How about this PR? https://github.com/multitheftauto/mtasa-blue/pull/390

einheit-101

2018-09-06 17:43

reporter   ~~0026983

This PR may be able to manipulate dummy Positions, but it still cannot overwrite dummy rotations (wheels...)

Issue History

Date Modified Username Field Change