View Issue Details

IDProjectCategoryView StatusLast Update
0007076Multi Theft Auto : San AndreasClientpublic2012-06-28 23:04
ReporterWafamdeAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.3.1Fixed in Version1.3.1 
Summary0007076: engineReplaceCOL only works inside streaming range.
Description

Unlike other engine* funcs and removeWorldObject, engineReplaceCOL only works inside streaming range. I have been removing parts of world objects and had to remove their collision objects as well.

I discovered that when I was close to the area (inside streaming range) that I wanted to replace an object in, as expected, the dff wasnt replaced properly because I was inside streaming range, but the col was replaced somehow.
I tried flying out of streaming range and update the resource, when I came back to the same area, the dff had been replaced but the col had not been replaced.. Meaning it was restored to the original collision object even tho the output told me it succeeded.

Steps To Reproduce

Stand near a collsion object you want to get rid of.

Start the resource when you are inside streaming range.
You will be able to pass through it.

Get out of streaming range, restart the resource, go back to the object and try to pass through it again. This will fail.

TagsNo tags attached.

Activities

Issue History

Date Modified Username Field Change