View Issue Details

IDProjectCategoryView StatusLast Update
0007068Multi Theft Auto : San AndreasServerpublic2014-06-14 06:17
ReporterWAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSLinuxOS Version
Product Version 
Target VersionFixed in Version1.4 
Summary0007068: setPedAnimationProgress crashes clients when performed on unstreamed peds
Description

setPedAnimation on peds/players crashes all clients, that don't have this ped streamed in.

Steps To Reproduce

Make sure you're not nearby 0,0,0 and then execute this code (server-side):

local ped=createPed(0,0,0,5)
setPedAnimation(ped, "benchpress", "gym_bp_geton", -1, false, false)
setTimer(function()
setPedAnimationProgress(ped,"gym_bp_up_B", 0.5)
end,1000,1)

Additional Information

Complete test resource for this issue: http://fullserver.eu/pio/tmp/lss-test.zip

Tested on:
sver: v1.3-release-4004
ver: v1.3-release-4037

TagsNo tags attached.

Activities

W

2012-05-11 10:01

viewer   ~~0016634

Last edited: 2012-05-11 10:31

I wrongly described crashing function - it's setPedAnimationProgress, not setPedAnimation. Also, it occurs only if it is executed server-side.

Also, above example has wrong animation name, bugreport can't be edited by me, but it was fixed in linked test resource, and crash still occurs.

sbx320

2014-05-23 01:17

administrator   ~~0020928

Linked resource is down and I'm unable to reproduce it with the code above (with fixed animation). Does this still happen for you in some special circumstances?

W

2014-05-23 08:49

viewer   ~~0020931

I can't reproduce it anymore, seems to be fixed.

Issue History

Date Modified Username Field Change