View Issue Details

IDProjectCategoryView StatusLast Update
0006992Multi Theft Auto : San AndreasClientpublic2018-03-04 17:39
ReporterXeonAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status confirmedResolutionopen 
Product Version 
Target VersionConfirmed IssuesFixed in Version 
Summary0006992: Markers attached to bikes don't follow the bike leaning
Description

Markers attached to bikes don't properly follow the bike's "leaning" when turning. I have tried it with a corona marker and most bikes. Objets do properly follow the bike's leaning when attached to one.

Steps To Reproduce

addEventHandler("onPlayerVehicleEnter", getRootElement(), function(vehicle)
local vtype = getVehicleType(vehicle)
if (vtype ~= "Bike") then
return
end

local object = createMarker(0, 0, 0, "corona", 0.25, 255, 126, 0)
attachElements(object, vehicle, -1, 0, 1)

end)

Then get on a bike and start turning. See attached file.

TagsNo tags attached.

Relationships

has duplicate 0007875 closed New issues Corona Marker attached on Motorcycle 

Activities

Gallardo9944

2014-02-18 18:03

viewer   ~~0020240

Last edited: 2014-02-18 18:03

View 2 revisions

The same problem appears when using processLineOfSight - it returns a position of collision of the bike, but when it's leaning, the position doesn't change, so the collision position is somewhere "floating" near the bike.

qaisjp

2014-11-16 02:11

administrator   ~~0022411

I remember reproducing this at one point in time.

arranTuna

2014-11-16 12:52

manager   ~~0022440

Confirmed with the code in steps to reproduce.

MrTasty

2018-03-04 17:39

viewer   ~~0026447

Same problem with getVehicleComponentRotation -- it doesn't take into consideration the tilt of the bike when turning.

Issue History

Date Modified Username Field Change