View Issue Details

IDProjectCategoryView StatusLast Update
0006571New Feature RequestsGeneralpublic2018-09-05 22:18
ReporterKenix Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionsuspended 
Summary0006571: Add opportunity to add new ids
Description

Add opportunity to add new ids for: objects, skins, vehicles, weapons.

TagsNo tags attached.

  Users sponsoring this issue
Sponsors List Total Sponsorship = EUR 766

2012-12-26 01:10: mabako (EUR 5)
2013-02-23 11:53: x0rh4x (EUR 10)
2013-03-09 18:20: CoolDark (EUR 1)
2013-03-30 11:33: rachet (EUR 1)
2013-05-25 08:23: Kunal (EUR 1)
2013-06-30 19:49: Demetr1us (EUR 1)
2013-09-04 18:11: Exciter (EUR 10)
2013-10-29 14:46: lopezloo (EUR 1)
2015-01-02 05:52: Muffins (EUR 50)
2014-12-18 22:32: Emilio_Maestro (EUR 35)
2014-12-19 00:00: Strix (EUR 1)
2014-12-28 03:48: castillo14 (EUR 40)
2015-02-12 11:27: nokizorque (EUR 10)
2015-02-23 21:40: Xeee (EUR 10)
2015-03-15 13:44: DLmass (EUR 50)
2015-04-21 19:49: socialz (EUR 20)
2015-12-22 13:10: dfigfjf (EUR 50)
2016-12-31 01:37: myonlake (EUR 20)
2017-01-17 17:50: stumpy (EUR 50)
2017-01-17 18:01: HorrorClown (EUR 200)
2017-01-17 18:03: KroxD (EUR 200)
  Users sponsoring this issue (Total Sponsorship = EUR 766)

Relationships

has duplicate 0007110 closed New issues New models 
has duplicate 0007267 closed New issues Ability to add new object to the game 
has duplicate 0008776 closed Multi Theft Auto : San Andreas Ability to create custom weapon 
child of 0003344 closed New Feature Requests Requested features tracker 
child of 0007728 closed Multi Theft Auto : San Andreas Things that need doing before we can even think about "Adding the opportunity to add new IDs" 

Activities

NikDelgad

2011-10-01 23:15

viewer   ~~0014999

Remi-X is on drugs. But on Topic. I hope this will be implanted in 1.2 or whatever version. It would be so great.

CWanted

2012-08-24 11:55

updater   ~~0017361

http://bugs.mtasa.com/view.php?id=7110

Kenix

2012-08-24 13:35

updater   ~~0017363

Look at submit date.

Kenix

2012-09-10 14:51

updater   ~~0017523

Last edited: 2012-09-10 21:01

Also i think need add ability to add new id's for weapons too.


function addNewID

Arguments:
1) Id for model
int id

2) Replace what? Types here:
string
'object',
'skin',
'vehicle',
'weapon'

Return false if model replaced or arguments are wrong.

Some examples:

-- Weapon
local n = addNewID( 19999, 'weapon' )
setWeaponProperty( n --[[ arguments ]] )

pTxd = engineLoadTXD ( 'weapon.txd' )
engineImportTXD ( pTxd, n )
pDff = engineLoadDFF ( 'weapon.dff', n )
engineReplaceModel ( pDff, n )

-- Skin
local n = addNewID( 20000, 'skin' )

pTxd = engineLoadTXD ( 'skin.txd' )
engineImportTXD ( pTxd, n )
pDff = engineLoadDFF ( 'skin.dff', 0 )
engineReplaceModel ( pDff, n )

-- Vehicle
local n = addNewID( 20001, 'vehicle' )
setModelHandling( n --[[ arguments ]] )

-- Client

pTxd = engineLoadTXD ( 'vehicle.txd' )
engineImportTXD ( pTxd, n )
pDff = engineLoadDFF ( 'vehicle.dff', 0 )
engineReplaceModel ( pDff, n )

-- Object

local n = addNewID( 20002, 'object' )

pTxd = engineLoadTXD( 'object.txd' )
pCol = engineLoadCOL( 'object.col' )
pDff = engineLoadDFF( 'object.dff', 0 )

engineImportTXD( pTxd, n )
engineReplaceCOL( pCol, n )
engineReplaceModel( pDff, n )

createObject( n, 0, 0, 0 )

...

Hyunsu2

2012-12-27 07:14

viewer   ~~0017925

I look forward to it!!

Cazomino05

2012-12-29 19:24

reporter   ~~0017927

don't expect this remotely soon, until we can set data that would be in
objects.dat
peds.ide ... I forget the name but whatever
vehicles.dat
carcols.dat
handling.cfg
weapon.dat

I don't think you will ever see more weapons in GTA:SA or MTA:SA by extension, I only expect vehicles, peds and objects to work.

Hyunsu2

2012-12-30 07:03

viewer   ~~0017931

Cazomino// So then, Can you make it possible to set weapon property of each peds.
If you do that, i can mimic customweapon.
So i will be happy.

Kenix

2013-01-01 13:08

updater   ~~0017936

Last edited: 2013-01-01 13:32

Try to make weapons too if possible pls. I want see weapon packs on servers with tactics like gamemode :D It's wonderful.

csmit195

2013-01-24 05:32

viewer   ~~0018008

I agree, to be able to add more objects would be cool, so we dont have to replace them, but one problem ,i have never seen a GTA:SA Mod do it before, so i'm not sure if its possible.

tinostar91

2013-02-01 14:34

viewer   ~~0018084

Last edited: 2013-02-01 14:36

@csmit195 there are many mods which have their own new objects in SA, but only objects and nothing more. Objects in these mods are stored in separate .img files so if MTA team will find somehow how MTA can add objects to .img files (create blank .img file where new objects will be stored?) with ID defined in lua script it can be but this should be solution only for objects, for cars/weapons you still need to add flags, handling....

Muffins

2013-05-03 12:05

viewer   ~~0018470

Any updates on this?

CoolDark

2013-05-05 07:43

viewer   ~~0018483

2012-12-29 19:17Cazomino05 ETA none =>1 month

Why have not already done? :(

tinostar91

2013-05-05 09:09

viewer   ~~0018484

You forgot 1 symbol, it says more than 1 month, not only 1 month
none => > 1 month

Kenix

2013-05-05 21:57

updater   ~~0018504

Source code of the newest version Limit Adjuster
http://www.aschratt.com/index.php?p=downloads&id=5

Muffins

2013-05-25 08:09

viewer   ~~0018600

Any word from a dev on this?

Pallanas

2013-06-01 22:53

viewer   ~~0018630

Bump ?

Muffins

2013-06-26 13:40

viewer   ~~0018828

...

Noneatme

2013-07-02 21:17

viewer   ~~0018849

I think there is an association with MTA:Eir.
Maybe they will wait until something happens. (I guess lol :D)

Cazomino05

2013-07-23 02:48

reporter   ~~0018965

this is asking a lot it's by far our biggest feature and should by rights be split into smaller issues

Muffins

2013-09-04 19:45

viewer   ~~0019272

^So you're actually working on this? I mean, 59 euros have been donated for this. it might not be much as there are a handful of devs, but it's something.

CWanted

2013-09-14 11:12

updater   ~~0019323

Last edited: 2013-09-14 11:12

View 2 revisions

What about 590 euros? Did you even read https://bugs.mtasa.com/view.php?id=7728 ?

qaisjp

2013-10-29 14:49

administrator   ~~0019581

€60, thinking about it how about a "custom.img" in the mtaserver conf?

lopezloo

2013-10-30 15:31

developer   ~~0019584

2013-10-29 16:50 arranTuna Sponsorship Deleted arranTuna: EUR 30
?

Cazomino05

2013-10-30 15:37

reporter   ~~0019585

it doesn't matter it wasn't being done anyway you'd have to be mad to look at the list of things that need doing and think it'd be fun, easy or quick to do.

arranTuna

2013-10-30 20:04

manager   ~~0019586

@ lopezllo I removed my sponsorship because:

  1. The issue description is poor, it's not even a proper sentence, yet the work required is astronomical, so I don't really see why such a poorly detailed issue should get a sponsorship. This #7728 is much more detailed and that's only what has to be done before this issue can even be completed.

  2. The work required is so astronomical that I don't expect anybody will ever unnecessarily sacrifice so much of their time for it.

  3. For me the main interest is being able to add new objects and according to that detailed issue, objects require a lot less work than something like vehicles. As this issue requests everything, it makes the chance of any part being completed being significantly less likely, a different report for each element type would be a lot more realistic.

  4. It would take 10 more people to sponsor the same amount I sponsored for anybody to be even motivated by it, not that sponsorships are motivating because the developer(s) wouldn't get the sponsorship anyway.

  5. It's also annoying that so many people are abusing the sponsorship system, 5 people including yourself all sponsored this issue 1 euro which you obviously have no intent of paying you just simply want to bump it. Only me and about 1 other person has ever committed to their sponsorships.

ata123456789

2013-11-14 21:56

viewer   ~~0019665

Last edited: 2013-11-14 21:56

View 2 revisions

Possible to increase the .IDE limit in SA bigger than 20.000?

fastman32:
There's a problem with hacking this limit due number of references to _modelPtrs array, there are about 1000 references and no one can hack as many references without a single error. Not only it would be time consuming, but there's a great chance for an error.

Emilio_Maestro

2014-12-18 22:39

viewer   ~~0022701

Last edited: 2015-01-01 13:55

View 2 revisions

I add 10€ ! I really need that... ( object ) Regards,

Emilio_Maestro

2015-01-01 13:51

viewer   ~~0022773

Why my sponsor was change ?! I cant modify it. I promess 10€ not 9999€wtf..

einheit-101

2015-01-02 12:10

reporter   ~~0022782

Emilio make "add sponsorship" then enter a value of -9989

Emilio_Maestro

2015-01-28 23:23

viewer   ~~0022939

Thx ;)

Hyunsu2

2015-03-12 01:21

viewer   ~~0023088

Last edited: 2015-03-12 01:21

View 2 revisions

In case adding object model, How about downloading custom object with MTA Client? (like samp)
Then, we can replace the custom object.

Emilio_Maestro

2015-03-14 17:59

viewer   ~~0023090

Total Sponsorship = EUR 171

Date Submitted : 2011-10-01 18:24

It's time to do that ! :)

pasta50

2015-03-15 13:15

viewer   ~~0023091

@Emilio_Maestro

No. It will not be done in near future. There is simply lack of developer time and many other things will need changing to even have possibility creating the part of ID's, total amount of donations flooding in and all arrogants that like to bump this mantis ticket with low donations/some increase will not get their right with it, because it isn't an right and the MTA developers arent planning to put any manpower on it yet as was made clear before. I'm not speaking out of myself, but of what's said already about the subject by MTA team. If you guys keep bumping it up with your own desire to get it looked at, 1. it won't speed up as there's still no workable factor (enough developer time) and if its ever done, no word will come from 70% of all 'sponsors' anymore about it. I urge you to stop your campaign, donate-add what you want to but besides that, no-one cares about what you want. Do you have a problem with that, is it already clear to you guys? The thing is there are many ppl that want this to be created, not that your selfishness of what you want here will help this to be developed. MTA developers already know of that it's an supported suggestion to be created, but in the end this mantis # might even get deleted, locked or disabled from bumps as this is already clear. I think developers dont even get affected anymore by every new reply/note because types like yourself are too active in striving for your own wished feature.

Please refrain from adding tiny bits by tiny donations, Emilio_Maestro, and add at once what you want to sponsor for it. How hard can that be?

arranTuna

2015-12-22 16:48

manager   ~~0024255

Since someone just bumped this I'll mention that adding new ID's for peds isn't needed as 237 new skin ID's were added in 1.6-7701 which needs extensive testing, specifically applying mods to those new skins: https://wiki.multitheftauto.com/wiki/Character_Skins

ata123456789

2015-12-26 14:53

viewer   ~~0024263

http://gtaforums.com/topic/733982-fastman92-limit-adjuster/

Since more than 1 year possible to add new IDs over 20k, it's a bit late but I didn't knew it.

Proof:
http://gtaforums.com/topic/776561-wipbetasa-gta-underground-savclc-other-maps/page-67
http://gtaforums.com/topic/813938-saxvcxlc-vc-and-lc-in-san-andreas/page-1

einheit-101

2015-12-27 02:35

reporter   ~~0024264

it would be far more interesting if you could copy vehicles such as Rhino, Forklift, Towtruck or Rustler that have special abilities, this would allow more than just 1 Tank and so on.

platinum

2016-02-03 07:05

viewer   ~~0024383

http://gtaforums.com/topic/839261-saxvcxlc-mta-compatible-build/

This release of SAxVCxLC comes with a custom MTA build that works with Fastmans Limit Adjuster and allows for up to ~26000 model ids with FLA.

qaisjp

2018-09-05 22:18

administrator   ~~0026955

Moved to https://github.com/multitheftauto/mtasa-blue/issues/384

Issue History

Date Modified Username Field Change