View Issue Details

IDProjectCategoryView StatusLast Update
0006338New Feature Requests[All Projects] Generalpublic2018-07-29 08:56
Reporterlil_ToadyAssigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
Summary0006338: [Request] A blacklist in the serverbrowser
Description

So those servers don't come up in the list

TagsNo tags attached.

Relationships

child of 0006334 closed Improve the server browser 

Activities

diegofkda

2011-08-10 00:15

viewer   ~~0014215

Sounds interesing, very interesing, I really like this idea, could be done in 1.1.0 :).

arranTuna

2011-08-10 00:17

manager   ~~0014216

Is the blacklist per player or per master server?

And is blacklisting only for those servers that copy the names of others?

Ca11um

2011-10-30 02:30

reporter   ~~0015161

I would think the latter would be better of the two, Arran. No point having it per-player, as it's very easy to just decide not to connect to a certain server. However, if the blacklist was moderated by MTA and applied to all clients, it would help put an end to servers that copy names and attempt to retrieve malicious data from their players (such as passwords, to use on other servers).

arranTuna

2011-10-30 10:38

manager   ~~0015163

Most servers are hosted by game server hosting which means the blacklist would have to be server:port and what if somebody else was then given that server:port?

Last thing MTA want is more people complaining that their server doesn't appear in the list as well as the conflict of interest that arises from having such powers.

I'd like to hear of some games or mods that have given themselves the ability to block servers and it has been successful in some way.

TF2 uses per player blacklisting but that can be furthered there was a database that stored peoples view of a server (either favourite or blacklisted) and then some column or label once clicked on that would show how many times favoured and how many times black listed.

qaisjp

2012-07-05 16:51

administrator   ~~0016963

Last edited: 2014-11-23 22:00

View 2 revisions

<snip code>

lil_Toady

2012-07-05 17:15

administrator   ~~0016968

I'm talking about client side black list here.

P.S. qaisjp, your code sucks, if a server has more favourites than dislikes, it will get blacklisted, and not the other way round.

Jaysds1

2012-09-01 03:56

viewer   ~~0017423

Last edited: 2013-04-17 02:30

xD, anyways, I like arranTuna idea, even though people aren't going to open up the tab to see if it's blacklisted or favourited, but it could work.

How about adding more columns in the server browser and calling them "Favourites" and "Blacklists", and to rate the server, you have to open up that server info window and click on some button either good or bad.

EDITED: Maybe we could also use the new server-id key since we're only using them so other servers wont copy/use the client-sided resources.

Issue History

Date Modified Username Field Change