View Issue Details

IDProjectCategoryView StatusLast Update
0005623Multi Theft Auto : San AndreasClientpublic2018-09-16 17:00
ReporterDevan_LTAssigned Toqaisjp 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0005623: Objects with alpha below 141 are invisible
Description

If you use setElementAlpha on object and set alpha to 140 or less, the object will be invisible. This must be a limitation of GTA, as breakable objects disappear without fully fading out when broken. However, I think there must be some other way to give objects transparency below 141. When you are going away from the object and reach its LOD distance, it fades smoothly. It'd be nice if MTA could apply this kind of transparency to objects, as I need smooth fading.

TagsNo tags attached.

Activities

TheGTA

2013-06-07 13:35

updater   ~~0018689

The problem was that MTA did not adjust render states (ALPHAREF stayed 100). I fixed this alpha issue for vehicles and objects, currently eir fork only, by rewriting RenderEntity.

qaisjp

2014-11-16 02:26

administrator   ~~0022419

confirmed

run o = Object(1337, getRandomPlayer().position)
run -- walk out of obj, look at obj
run o.alpha = 140 -- obj now invisible

arranTuna

2014-11-16 12:34

manager   ~~0022435

I've seen this fixed in the Eir branch.

einheit-101

2018-03-06 02:04

reporter   ~~0026449

There is more wrong with Alpha in MTA because players and some other elements are invisible behind glass and other transparent objects (Trees...)

Notice how CJ and that computer console are invisible behind that glass object, but the large building behind them and the stairs are clearly visible...
https://imgur.com/a/IeBqw

qaisjp

2018-09-07 09:42

administrator   ~~0026989

Moved to https://github.com/multitheftauto/mtasa-blue/issues/425

Issue History

Date Modified Username Field Change