View Issue Details

IDProjectCategoryView StatusLast Update
0005453New issuesVehiclespublic2018-07-21 16:53
Reporter[PS]DazzaJay[AU]Assigned Tomyonlake 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinux ServerOSLinuxOS VersionDebian Lenny
Summary0005453: Some vehicles without doors return door state 4 while others return nil.
Description

Basically, using getVehicleDoorState Some vehicles that do not have doors return "4" - Fallen off, while others (all boats and bikes) return "nil" - because there are no doors. I believe they should all return nil.

For example, all boats return "nil" and all bikes return "nil" - and I think all doorless vehicles should return nil, but some return "4" instead.
Here is the list of Doorless vehicles that return "4" instead of "nil"

RCRaider, RCBandit, RCTiger, RCCam, RCGoblin, Vortex, Mower, Bandito, Kart, Baggage, Forklift, Tractor, Caddy, Quadbike, BFInjection, Dozer

Steps To Reproduce

get into one of the listed vehicles and use getVehicleDoorState

TagsNo tags attached.

Relationships

related to 0009915 closed Changing vehicle model from doorless or "doorful" causes doors to fall off 

Activities

[PS]DazzaJay[AU]

2010-07-06 22:48

reporter   ~~0011702

Ah, was just experimenting and I believe I have discovered something this bug is related to. Remember the annoying Doors fall of vehicles on change bug?

Well, here's what I have noticed. Vehicles that return "nil" with their door states, (Boats and Bikes) When changing From these to cars, the cars HAVE all their doors.

BUT, when going from a vehicle that has no doors that returns "4" (Tractor) instead of "nil" The doors of the car you change to Will fall off.

I don't believe this is a coincidence.

To Reproduce, go from a Boat or Bike in Race, to a banshee. - Doors will stay on car.
then..
Go From a Tractor or BF injection to a Banshee - and its doors will fall off.

The Boat, Bike, Tractor and BF Injection all have one thing in common, No Doors.
However when using getVehicleDoorState the Boat and Bikes return "nil" while the Tractor and BF injection return "4"

I believe doors falling off while changing between vehicles, and this to be related.

myonlake

2018-07-16 23:13

updater   ~~0026738

I checked out this thing and it seems bikes and other doorless vehicles return a 0 state, not a nil, and it never should return a nil anyway.

So I believe this issue is sort of fixed. Even after you set the model, the state is the same... which brings us to the comment above:

If you set the model from a "doorless" vehicle to a "doorful" vehicle, it will automatically eject the doors off of the vehicle.

It makes sense why it does that at the moment, since it kind of has no clue of what the actual set state is, and just assumes that the previous state is correct. I think this needs some feedback from other devs on what should be done.

myonlake

2018-07-21 16:47

updater   ~~0026757

It has been returning 0 for a while, I'm unable to find any commits related to this for now...
Closing, this is 8 years old.

Issue History

Date Modified Username Field Change