View Issue Details

IDProjectCategoryView StatusLast Update
0005072New issuesClientpublic2018-09-24 21:23
ReporterR3mpAssigned To 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionsuspended 
Summary0005072: createProjectile creates one projectile for every person in the vehicle
Description

if the local player is in a vehicle when using createProjectile, 1 projectile for every person in the vehicle will be created (1 if hes alone, 2 with 1 passenger and so on)

this doesnt always happen to every person in the vehicle, occasionally you can create single projectiles without issue. it seems passengers are more likely to have the problem

have only tested with grenades and molotovs

Steps To Reproduce

have someone else drive a vehicle, get in as passenger and /fire, you should see 2 distinct grenades being created (or, if they are particularly close together, 2 explosions)

addCommandHandler("fire",function()
local x,y,z = getElementPosition(getLocalPlayer())
createProjectile(getLocalPlayer(),16,x,y,z+1,0.5,nil,0,0,0,0.2,0.2,0.2)
end)

TagsNo tags attached.

Activities

50p

2012-09-12 00:50

reporter   ~~0017542

I can't believe it hasn't been fixed yet.
Anyway, using createProjectile while sitting in a vehicle will not pass the "creator" parameter in onClientProjectileCreation on remote clients (both clients are close to each other so they're streamed).

einheit-101

2014-03-19 17:54

reporter   ~~0020423

Does this old bug still exist?!

arranTuna

2014-03-19 20:49

manager   ~~0020425

Test it and see?

einheit-101

2014-03-20 14:13

reporter   ~~0020426

i try to get someone else for testing asap. I am currently working with projectiles but alone and everything works fine for me as the only Player.

lopezloo

2014-03-20 15:29

developer   ~~0020427

Last edited: 2014-03-20 15:33

View 3 revisions

Reproduced in 1.3.5-release-6178.3 while local player was passenger. I can't reproduce while I am driver (or when I put other player - passenger - as creator).

arranTuna

2018-09-24 21:23

manager   ~~0027076

Moved to https://github.com/multitheftauto/mtasa-blue/issues/584

Issue History

Date Modified Username Field Change