View Issue Details

IDProjectCategoryView StatusLast Update
0004921Multi Theft Auto : San AndreasSynchronizationpublic2018-09-05 17:51
ReporterkwksndAssigned To 
PrioritylowSeveritymajorReproducibilityalways
Status closedResolutionsuspended 
Product Version1.0 
Target VersionFixed in Version 
Summary0004921: Improve ped synchronization
Description

this issue is very hard to describe so i have included a video and the test resource i was using to make the vid

but the issue is the torso of a ped does not aim at the target when shooting
http://www.mediafire.com/file/wt4znmjrzjm/ped issue.avi

seems he only likes certain directions when shooting
his feet and head aim at the player he is shooting at but the torso does not

here is a test script i was playing with
http://www.mediafire.com/file/mmcuwkmjynz/KWKPedWithWeapon.zip
i know its not a finished script and has bugs
i didn't make it so it can deal with more than one target yet so in testing this please test alone

Additional Information

it is possible this is my scripts fault but i dont see the problem. after all i have no way of controlling the torso of a ped.

also others are having the same issue
it also seems to vary alot with different weapon types

TagsNo tags attached.

Relationships

parent of 0004896 closed Ped vehicles are not jackable 

Activities

kwksnd

2009-08-31 07:05

reporter   ~~0010383

also i forgot to add that we really should have a function for aiming peds at a given target. so he always faces it as long as thats his target

setPedTarget(theped,(player,vehicle or object etc))

Dragon

2009-08-31 10:32

reporter   ~~0010384

did you try setPedRotation?

Paul_Cortez

2009-11-15 22:03

reporter   ~~0010792

Walking and driving of peds is also horrible with multiple players. We've played several rounds of a mode with about 40 peds. The peds were walking pretty ugly. Also, almost every round had at least 1 or 2 peds which were "invincible".

When the "invincible" issues occurred, the peds weren't on the right position for ANY client. Out of 3 people on the server, all saw the ped on another position. The server even decided to try to be funny and had another position as well.

To give you an idea, here are the positions:

  • Position according to me: Somewhere in the control room at Area 51
  • Position according to dragon: Somewhere in the middle of Area 51
  • Position according to Slothman: Somewhere on the second floor of the deep hole at Area 51
  • Position according to server: Somewhere on the second floor of the deep hole at Area 51

Peds would be awesome to have in MTA when these problems are solved.

Maccer

2010-04-29 06:10

viewer   ~~0011399

@Paul_Cortez:

Some ped actions aren't synced server-side, so they have to be implemented client-side with triggers.

PhatLooser

2010-05-03 16:06

reporter   ~~0011415

Last edited: 2010-05-16 01:29

Following ideas:
-Every player can damage peds, not only the syncer. Some cheats create invincible peds... And extreme lag does so,too.
-The ped's target automatically becomes the syncer, when aiming or shooting (?)
-Let the server be responsible for position and rotation, sometimes the object syncer does not react at all and the NPC does not rotate, but run against a wall.

izstas

2010-12-07 17:54

developer   ~~0012232

MTA has perfect player synchronization. Cannot it be used to synchronize peds?

ccw

2010-12-11 05:31

administrator   ~~0012244

Player sync uses more bandwidth.

You could try making a script which always set a peds syncer to be the nearest player.

PhatLooser

2010-12-15 23:43

reporter   ~~0012282

@ ccw:
Sorry to say that this won't work, since the "nearest player" may be one of those 800-ms-lag-dude with 10 frames per second.
What troubles me a bit is how to make the ped move at a changeless speed, not depending on the current syncer - the server does not have any collision files.
If all the syncers had 30 ms ping and 30 or more fps, the lags are pretty - tiny.

wormz

2014-12-11 08:43

viewer   ~~0022661

Add the ped actions Missing @PAulcortez better goal of this

haron4igg

2016-11-09 12:55

viewer   ~~0025379

@ccw:

Not sure that current ped implementation consumes less traffic then player sync:)
https://www.dropbox.com/s/2zy20a6vi514l7y/Screen%20Shot%202016-11-09%20at%2013.52.48.png?dl=0

Issue History

Date Modified Username Field Change