View Issue Details

IDProjectCategoryView StatusLast Update
0004504Multi Theft Auto : San AndreasClientpublic2018-09-18 18:47
ReporterBossAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0004504: Peds shooting incorrectly
Description

Peds are shooting away from the player while they're not supposed to (aimed directly at player's coordinates). This can be "fixed" by alt+tabbing out of SA and back in. A sample script to reproduce the bug included.

Additional Information

Commands to reproduce the bug:
"start peds"
"ped 33"
"giveweapon 25"

Then you'll see that the ped is shown shooting away and doesn't hit the player. Alt+tab to the desktop and back and you'll see that, even though the ped is still shown shooting away, he succesfully hits you.

TagsNo tags attached.

Relationships

has duplicate 0009147 closed New issues Bug Ballet Weapon - Client 
related to 0008482 closed New issues MTA internal functions returning NaN values 

Activities

qaisjp

2014-11-16 19:12

administrator   ~~0022466

Last edited: 2014-11-16 19:36

View 4 revisions

cant reproduce using resource. ( but i managed to do this, weapon creation doesn't work http://youtu.be/Wf4gpj-YukE )

arranTuna

2014-11-16 19:36

manager   ~~0022468

Last edited: 2014-11-23 00:57

View 2 revisions

I've simplied his test resource, just do /peds and the ped will start shooting at you, but their aim is completely wrong, I added a line between start aim and start end to prove he's meant to be aiming there but it's like he's shooting at you, but isn't.

I've also experienced this problem when making peds that are meant to shoot, this bug basically makes it impossible to have a game mode that relies on fighting peds.

Edit: I've been working with peds again and keep getting this bug so I debugged it some more and turns out that what it's meant to be aiming at is completely wrong to what it should be aiming at, the X Y and or Z randomly become NaN which is why they're usually aiming direction is all wrong. It doesn't happen if stood still but as soon as you start moving the XYZ start becoming NaN.

I was able to successfully mitigate this bug by having the ped stop shooting for 100ms every 1000ms. After he stops shooting, the XYZ stops being a NaN until it happens again in a few seconds time.

Issue History

Date Modified Username Field Change