View Issue Details

IDProjectCategoryView StatusLast Update
0004360Multi Theft Auto : San AndreasGeneralpublic2009-05-25 11:57
ReporterLordAzamathAssigned ToCazomino05 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0 
Summary0004360: AC kicks on exessive setElementHealth
Description

When using lot's of setElementHealth, AC has kicked me twice.. I don't know how to reproduce it, because most of the time, it doesn't kick me..

Additional Information

1st time: Was setting my own health less when my car gets damaged. Then simulated the damage with a command handler and after spamming it to the chatbox suddenly got kicked.. Never happened again till today. Don't remember the exact revision.

2nd time. I was testing the same script again and one guy was shooting a minigun against my car. Which means it set my health down pretty fast. Then suddenly got kicked by AC. This was done with r953. Only happened once, so can't give any steps to reproduce and I think that the script itself is irrelevant.. More to do with setting element health fast I think.

Both were similar on one thing though. Local player's health was set, when his vehicle's health got changed (triggered client event). First time it kicked me when my vehicle blew up, maybe there is some setElementHealth involved again..

TagsNo tags attached.

Activities

lil_Toady

2009-05-24 19:09

administrator   ~~0009367

it couldn't kick you for damaging the vehicle. Do you have that script cause of which you got kicked?

LordAzamath

2009-05-24 19:16

viewer   ~~0009368

Last edited: 2009-05-24 19:19

Umm okay..
http://www.turboupload.com/v3iok3hvc6d9/crashControl.zip.html

I rather think it kicked because I set my own health client side.. Which is just done after damaging the vehicle..

Note though that this isn't easily reproducable. Only kicked me two times out of all times I've ran it.
EDIT: Umm.. I accidentally gave you the fully working version, which doesn't set ppls health on vehicle being shot at. So you'd need to remove onClientPlayerWeaponFire event handler from client side.

GrimReaper

2009-05-25 00:40

viewer   ~~0009374

Last edited: 2009-05-25 00:46

something similar just happend to me.
i flew over my sam installation. one rocket hit the chopper, then i jumped out.
a second rocket hit the chopper while the script still counted me as "occupied seat id 0". the 2nd rocket made the chopper explode. i recieved damage by the rocket or chopper explosion, or both. when my ped hit the ground and died, i got kicked. i just don't know if it still counted me as occupant when i hit the ground. this took something from 1 to 2 seconds. this happened with r938.

i found this in the console:
healthCheck: 0.000000 -0.134842
armorCheck: 0.000000 0.000000

Cazomino05

2009-05-25 01:11

reporter   ~~0009375

Fixed in r965

Issue History

Date Modified Username Field Change