View Issue Details

IDProjectCategoryView StatusLast Update
0004185Multi Theft Auto : San AndreasServerpublic2018-10-22 23:52
ReporterNeonBlackAssigned Tolopezloo 
PrioritylowSeverityfeatureReproducibilityalways
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0004185: Door States 1 and 3 need a “love tap” or should make the door unclosable
Description

The door states 1 and 3 don't work.
If such a state is set the door should be pushed a bit away from the car so that they don't shut immediately after getting the free swinging state.

Another - imho - better idea would be to make the door unclosable in states 1 and 3 so that they've no other choice than be free swinging.

This feature would be nice for an open/close cargo bay script.

Btw the hood springs already open if it's state is set to 3. (But not for 1)

TagsNo tags attached.

Relationships

has duplicate 0005702 closed New issues Setting vehicle door state to 1 closes the door 
has duplicate 0008188 closed New issues setVehicleDoorState, getVehicleDoorState don't correctly work with states 1 and 3 
related to 0009788 closed New issues setVehicleDoorState bug 

Activities

eAi

2009-05-11 02:26

administrator   ~~0009192

We're proposing adding setDoorAngle and various associated functions. These may have to wait till post 1.0 now though.

Grafu

2014-04-18 12:19

viewer   ~~0020707

Last edited: 2014-04-18 13:18

View 4 revisions

Requires double calling.

For state 1

setVehicleDoorState(vehicle, door, 1) --to make sure we get intact state
setVehicleDoorState(vehicle, door, 3) --will set the door to swinging

For state 3

setVehicleDoorState(vehicle, door, 2) -- will make the door damaged
setVehicleDoorState(vehicle, door, 3) --call this to get swinging door

Strangely these 2 states requires to be called in combinations to get the desired effect. I believe something can be done in the code of MTA using the same technique to fix the bug.

The code, if somebody needs:

_setVehicleDoorState = setVehicleDoorState
function setVehicleDoorState(vehicle, door, state)
outputChatBox("Door: "..door.." "..state)
if tonumber(state) == 1 then
_setVehicleDoorState(vehicle, door, 1)
_setVehicleDoorState(vehicle, door, 3)
elseif tonumber(state) == 3 then
_setVehicleDoorState(vehicle, door, 2)
_setVehicleDoorState(vehicle, door, 3)
else
_setVehicleDoorState(vehicle, door, state)
end
return true
end

Still having problems getting the door states. Because if door effect state is 1, getVehicleDoorState returns 3, so this is up to MTA team to fix.

lopezloo

2017-05-27 00:21

developer   ~~0025988

https://github.com/multitheftauto/mtasa-blue/pull/143

lopezloo

2018-10-22 23:52

developer   ~~0027099

Moved to https://github.com/multitheftauto/mtasa-blue/issues/663

Issue History

Date Modified Username Field Change