View Issue Details

IDProjectCategoryView StatusLast Update
0003989Multi Theft Auto : San AndreasClientpublic2009-02-12 19:09
ReporterPaul_CortezAssigned Tolil_Toady 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0003989: Issues with disconnecting/reconnecting concerning community accounts
Description

I've only tried it on my server which has verifyserials on since the auto-login works. So when I reconnect, I get the message "Invalid serial" in the server console, and a message pops up like "Login blah blah". (forgot the text)

Problem is, I already AM logged in... Even if I go into settings>community, it even shows me I am. But no matter how many times I try to connect to the server, it just gives me the message over and over again.

The only solution is relogging. This brings me to another bug, which, I think, is related. When pressing logout and then login again in the settings>community tab, it says "Wrong username/password"... The password is quite long for some reason by the way. It seems like it's saving the password hash instead of the password itself... Although I don't know if this has anything to do with it.

I also asked someone else to reconnect once, and the same thing happened to him. He also had to relog and also had to re-enter the (correct) password in the password field to make it work.

Nightly is r264. (not sure about the other guy)

TagsNo tags attached.

Relationships

related to 0004090 closed Cannot connect to server due to needing a community login, When logged in. 

Activities

scarface1994

2009-01-23 23:12

viewer   ~~0008315

confirmed, reproducibility always.

Issue History

Date Modified Username Field Change