View Issue Details

IDProjectCategoryView StatusLast Update
0003975Multi Theft Auto : San AndreasClientpublic2009-02-26 03:58
ReporterPaul_CortezAssigned Toccw 
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0003975: Localhost desynch.
Description

There seems to be more desynch on localhost than on a remote server. For instance: In race, setVehicleModel is used a lot. But when connected to localhost, I have it a lot of times that it doesn't change to me.

Result? I had a map where I drove up against a heli transformer pickup, and I remained a car. And people called me a "heli driver", since I was a heli to them but driving like a car. Then later, someone else picked it up, and he became a FLYING CAR. (to me)

Another thing especially noticed with race, warpPedIntoVehicle doesn't seem to work correctly sometimes on localhost. You'll get the same kinds of symptons, not warping into vehicles and getting NETWORK TROUBLE. But this can also happen to other players not warping in, and that you DID jump in. Meaning that that player will remain at the start to you.

Both are annoying, and due to overuse in race, especially noticeable over there. Not immediately usually, but after some time of playing it should already have occurred.

Additional Information

This only seems to happen on my own server, others can just play normal but I can't. Switching 127.0.0.1 to my external IP didn't resolve the problem. Nightly is r148.

TagsNo tags attached.

Relationships

parent of 0003906 resolvedccw Sometimes using getElementID serverside retrives the id serverside, but it is an empty string clientside 
parent of 0003629 closed Sometimes using createObject/createPickup creates the object serverside, but it does not exist clientside. 

Activities

Talidan

2009-02-11 19:49

administrator   ~~0008356

This needs retesting as of r301

Talidan

2009-02-18 22:35

administrator   ~~0008395

Interestingly this time round its reproducable in Nightly and release, but not debug

Talidan

2009-02-19 17:02

administrator   ~~0008398

Needs retesting as of r330 or higher

eAi

2009-02-19 18:30

administrator   ~~0008402

Reducing the optimisation level is not a good solution, the underlying issue should be found.

Issue History

Date Modified Username Field Change