View Issue Details

IDProjectCategoryView StatusLast Update
0003953Multi Theft Auto : San AndreasWeaponspublic2009-03-22 16:28
ReporterTwigAssigned ToArc 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0003953: Projectiles don't sync correctly until player respawns once
Description

As description, projectile weapons including rockets, satchels, molotovs, grenades etc. don't sync between players until either one or both players have respawned at least once within the server.

Additional Information

This was tested using a fresh install of r182 on the test server.

TagsNo tags attached.

Relationships

related to 0002629 resolvedArc First two or three bullets of walking weapons don't hit the target after reloading 

Activities

ryden

2008-12-28 22:01

manager   ~~0008273

Last edited: 2008-12-28 22:01

This can be related to a bug that also affects sawnoffs.

It's a bug in which you see the remote player shooting anywhere instead of the target. Also, with rocket launchers you see the remote player like shooting but you don't see the projectile.

It's caused by the remote client and server sending you the remote player shooting state ( reloading, shooting, etc... ) and ammo in clip updated before you even see them shooting, causing to abort the shoot.

Willy

2009-02-12 23:04

updater   ~~0008359

bug still present in r307 - imo needs fixing before 1.0

Arc

2009-02-12 23:29

administrator   ~~0008362

Doesn't seem to be that much respawning related. I still couldn't see any of Willy's rockets even after we both respawned.

subenji99

2009-03-14 02:52

viewer   ~~0008549

In r431, freeroam, with the Hydra's missiles, either remote clients couldn't see the missiles OR their client crashed to desktop.

[PS]DazzaJay[AU]

2009-03-14 20:20

reporter   ~~0008552

i can confirm what subenji99 says.
every time i fired rockets, i managed to Crash Winky's game.

Arc

2009-03-22 16:28

administrator   ~~0008596

Turns out this was actually down to camera sync not getting through (unreliable packets). The same thing affected explosion sync and possibly other things.

Issue History

Date Modified Username Field Change