View Issue Details

IDProjectCategoryView StatusLast Update
0003190Multi Theft Auto : San AndreasVehiclespublic2017-08-18 13:14
ReportermekoreaAssigned Toccw 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionmtasadm_v1.0-dp2 
Target Version1.6Fixed in Version 
Summary0003190: Dummy misplacement on custom vehicles
Description

http://img141.imageshack.us/img141/3800/customvehbugiu9.jpg
Custom vehicle models cause vehicle dummy positions to be misplaced to vehicle's 0,0,0 coordinates. (lights, ped seats, ect.)
ps. Works on rare occasions.

TagsNo tags attached.

Relationships

has duplicate 0004033 closed New issues engineLoadDFF doesnt load correctly most model dummies 

Activities

IJs

2008-02-04 07:04

administrator   ~~0007203

I think these might be dummies that were not present in the original model. I remember seeing things like spoilers working correctly though..

mekorea

2008-03-02 17:36

developer   ~~0007388

Not sure about that, since "ped_frontseat", "headlights", "exhaust", etc. dummies are also being created to 0,0,0 coords which are included in every car.

misco

2009-03-02 14:35

viewer   ~~0008438

There was an ability to reset this things to right position with engineRestoreCol but in nightly build its not working(probably).

Arc

2009-04-23 23:11

administrator   ~~0008897

The dummies do get loaded correctly the first time. However as soon as you load a second car, MTA makes SA load the dummies again (doesn't happen with unreplaced cars), apparently somehow setting them to the origin.

x86

2009-11-20 22:01

administrator   ~~0010796

I had this problem in DP2 with a infernus mod, which i still use in MTA 1.0.2.. it's no longer bugged @ here.

x86

2010-03-08 09:45

administrator   ~~0011131

Yep, saw this problem in 1.0.4-untested-16 on a car, but not all. I can upload a screenshot.

dragonofdark

2012-06-29 10:08

viewer   ~~0016910

I don't know if it is related, but when we replace a 2doors vehicle whith a 4doors, only 2 doors work.

CWanted

2012-06-29 11:58

updater   ~~0016911

Dragonofdark, you are just replacing model and textures. I guess you need to edit some handling flags.

dragonofdark

2012-06-29 23:44

viewer   ~~0016923

I don't think it's the handling flags as there is no difference between a 2door and a 4door vehicle in handling.dat and vehicles.ide. When we replace the model, only 2 dummies are recognized.

ccw

2012-06-30 04:07

administrator   ~~0016924

I think the original issue has been fixed for a little while.

In the case of 2/4 door vehicles, it looks like they are not interchangeable.

dragonofdark

2012-06-30 20:38

viewer   ~~0016933

Tested in Single Player, and it does work. So I'm pretty sure it's a problem with the replace engine from MTA.

CWanted

2012-07-03 09:41

updater   ~~0016949

I cann't find any info on how number of doors is set. Well, there are not much options: exact numbers may be hardcoded in exe or/and operated via main.scm

dragonofdark

2012-07-11 17:03

viewer   ~~0017030

So do you think we could fix this problem in mta ?

LeetWoovie

2012-07-11 17:12

viewer   ~~0017031

Please provide a download for this model. I want to inspect the model a bit and test this bug.

dragonofdark

2012-07-12 03:05

viewer   ~~0017038

It's simply the Rancher from the mission "Lure" remplaced with the FBI Rancher. http://www.solidfiles.com/d/7833f6f040/

CWanted

2012-07-12 13:00

updater   ~~0017044

Last edited: 2012-07-12 15:07

Rancher is 2-door, FBI Rancher is 4-door. The game won't recognize 2 additional passenger seats, because number of doors for Rancher is set as 2 and hardcoded. No matter how much passenger seats replacement has, the game will use 2 only. Same goes to other models.

dragonofdark

2012-07-12 22:55

viewer   ~~0017045

If this is hardcoded in main.scm, can we fix it in mta. And if it is in .exe ?

Cazomino05

2012-07-13 19:49

reporter   ~~0017049

Last edited: 2012-07-13 19:50

actually the game reads the passenger seats from the dff but MTA will ignore them because as usual someone hard coded a value and now it's going to take a major release to fix.

EDIT: Yes I have looked into adding passenger seats and have working code for it.

dragonofdark

2012-07-14 00:18

viewer   ~~0017055

Eh, good to see that this will be fixed ! Thanks ;)

einheit-101

2014-03-20 21:40

reporter   ~~0020433

Last edited: 2014-03-20 21:41

View 2 revisions

Some vehicles work, some have bugs. But i think this issue is related with #8020 because the way MTA reads the dummy positions seems not to be the best. I think it reads the raw dff positions but "misc_c" of the Rhino/S.W.A.T/Towtruck is able to change it`s position inGame (the muzzle position for tanks or the hook of the towtruck) so it may be better if MTA tries to get the real dummy position, not a constant dff entry. Otherwise nobody will ever be able to get the position of such components/dummies.

Cazomino05

2014-06-19 08:47

reporter   ~~0021057

I don't think you understand the issue with 8020, 8020 isn't that it's reading the raw dff position it's that the position you want is somewhere else.

einheit-101

2014-06-19 14:20

reporter   ~~0021064

Last edited: 2014-06-19 14:25

View 2 revisions

I opened the 3D Model and misc_c is exactly what i want :)
But no matter where misc_c really is, the position returned with getVehicleComponentPosition is always

x = 0
y ~ 6.48
z ~ 1.30

for unmodified Rhino models. Modified Rhinos return different values, and they are more crazy (like z = 100 or so)

€DIT::: I hope i understood you correctly :D

einheit-101

2015-08-14 13:16

reporter   ~~0023925

Can anyone still confirm this issue? I am using many custom models and i cant see any problem since ccw fixed issue 8020.

einheit-101

2017-08-18 12:18

reporter   ~~0026158

Pls close, any issue regarding dummy positions has been fixed.

If any issue still exists, then it's causes by a faulty 3D model.

Issue History

Date Modified Username Field Change