View Issue Details

IDProjectCategoryView StatusLast Update
0003040Multi Theft Auto : San AndreasGeneralpublic2009-03-28 01:48
ReporterChrMLAssigned Tolil_Toady 
PriorityhighSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0003040: Mouse freezing issues
Description

There are some issues reported at the forums of mouse freezing. Not sure what could cause it, maybe our input system?

Here's a post from the forum:
"Hey, im an XP user, and i have had the mouse issue in MTA Race and MTA DM, i have noticed it only seems to affect me when i have a USB mouse.

there is only one solution i have found other than buying a PS2 Mouse, and that is i keep my mouse moving constantly in all loading screens, not allowing it to stop, and once im in game, it works fine."

TagsNo tags attached.

Relationships

related to 0003966 closed Keysync synchronisation is not implemented for Mouse Input. 

Activities

erorr404

2008-01-28 22:21

developer   ~~0007185

Last edited: 2008-01-28 22:22

I'm not sure if this issue describes the problem I'm talking about (I couldn't find a closer match), but there is a big problem where the mouse does not rotate around the player when you start MTA:SA. It works in the menu and GUI, and the mouse buttons might even work, but the rotation of the camera doesn't. The only way to solve this is to close MTA.

It seems completely random, but happens often enough to be a big deal IMO.

Talidan

2008-01-30 13:22

administrator   ~~0007189

The solution is not to close MTA, its rather that MTA is out of focus.

MTA hooks all keys with its own keybinds system, including GUI and movement. Mouse movement is the only exception, which is handled by GTA. This is why if your GTA is out of focus, then the mouse will not work but everything else does.

Alt+tabbing back to MTA or clicking in the window or some other similar focusing solution resolves this.

erorr404

2008-01-31 12:16

developer   ~~0007190

Wierd, since I know I never alt-tabbed or did anything to get it out of focus.

scarface1994

2009-01-16 21:43

viewer   ~~0008304

i can confirm this, though it rarely happens and i don't have a usb mouse, erorr404's post is whats really happening

lil_Toady

2009-03-25 00:00

administrator   ~~0008623

Made gta get the focus once the game loads

Issue History

Date Modified Username Field Change