View Issue Details

IDProjectCategoryView StatusLast Update
0003020Multi Theft Auto : San AndreasGeneralpublic2009-03-23 15:42
ReporterIJsAssigned ToIJs 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version1.0 
Summary0003020: Server HTML-encodes the download URL specified in the config
Description

The server HTML-encodes all special characters specified in the httpdownloadurl configuration tag, and passes this encoded URL on to the client, in case an external webserver is used.

On client-side download upon connecting, the download may fail because the external web server fails to recognize the encoded URL.

Log snippets:
[03/Jan/2008:02:21:36 +0100] "GET /%7Emta/files//cdm/cdm_client.lua HTTP/1.1" 404 343 "-" "-"

TagsNo tags attached.

Activities

Arc

2008-12-28 20:16

administrator   ~~0008271

The url is sent to the client unmodified. Looks like it's encoded by the client when it does the http request instead.

IJs

2009-03-23 15:19

administrator   ~~0008600

CNetHTTPDownloadManager::EscapeURL is the culprit.

IJs

2009-03-23 15:41

administrator   ~~0008601

EscapeURL URI escaping function has been changed to only replaces spaces (' ') with their URI escaped counterpart. I reckon this should be enough to fix things.

Resolved in net module r532.

Issue History

Date Modified Username Field Change