View Issue Details

IDProjectCategoryView StatusLast Update
0002677Multi Theft Auto : San AndreasGeneralpublic2007-11-14 16:17
ReporterjbetaAssigned Tokevuwk 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAMD Athlon(tm) 64 X2 ~2.2GHzOSWindows XP Professional x64 SP1OS Version5.2, Build 3790
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002677: Serverside getResourceConfig returns an invalid xmlnode pointer for stopped resources
Description

Summary is self explanatory. Major as trying to run xml functions on this xmlnode can crash the server.

We can't test if the clientside version has the same problem, because you can't get a valid resource pointer for a stopped resource clientside.

Steps To Reproduce

/start runcode
/run getResourceConfig(getResourceFromName "edftest", "edftest.edf")

This will show the results of running tostring() on the returned xmlnode:
userdata: 00000000

TagsNo tags attached.

Activities

eAi

2007-11-13 09:46

administrator   ~~0006253

Is this only on resources that have been started then stopped?

jbeta

2007-11-13 09:48

updater   ~~0006254

Last edited: 2007-11-13 09:48

No, only on resources which haven't been started.

Running it on resources that have been started and stopped seems to return a valid pointer.

ChrML

2007-11-13 12:08

administrator   ~~0006257

Might've fixed it now. It returns false if the resource isn't started now.

eAi

2007-11-13 12:11

administrator   ~~0006258

I think we want server side configs to be accessible when resources are stopped... Initially they were disabled by default, but people needed access to them when they're stopped for the editor...

Talidan

2007-11-13 13:55

administrator   ~~0006260

i think its more sensible that we have special ACL functions to start resources with limits. I'll speak to you about it sometime

kevuwk

2007-11-13 13:57

administrator   ~~0006261

the reason these were disabled was the amount of memory they were using as soon as the server started running, the server was using say 8mb in debug mode without them then maybe 25mb (when we didn't have half the resource we have now) with them

Talidan

2007-11-13 13:59

administrator   ~~0006262

Then we should do what i just mentioned in irc: special ACL access to start resources with certain limits.

This means you can start a resource, but strip its script or map functionality so it wont interfere with the editor.

Issue History

Date Modified Username Field Change