View Issue Details

IDProjectCategoryView StatusLast Update
0002669Multi Theft Auto : San AndreasWeaponspublic2007-12-06 11:02
ReporterAlienXAssigned ToChrML 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002669: Able to pretend shoot any weapon from any vehicle (read description)
Description

Lets say you had a pistol in your hand and you were in a bullet.

Your able to pretend to shoot a player (guess where your crosshair is and fire), your player does nothing because your not ment to be able to shoot a pistol from a car, but on the remote side (the player you are pretend shooting at) sees you doing a drive by like normal and takes damage.

TagsNo tags attached.

Activities

AlienX

2007-11-09 10:00

viewer   ~~0006181

Please note, after further tests this only happens once you have shot all of your uzi ammo (even when your uzi is on 0-0 ammo, it still does the firing animation.

As noticed, you can use any weapon as a drive by weapon if you have the UZI in your inventory, once this is out of your inventory this bug can take place.

Talidan

2007-11-09 16:59

administrator   ~~0006182

Can you reedit the report, it really makes no sense.

As i gather from your note, the bug is that after you run out of ammo whilst in driveby mode, remote players see you shoot bullets when they shouldnt.

Correct?

AlienX

2007-11-12 07:49

viewer   ~~0006234

Here are some steps lol:
1) Give yourself weapon 28 (any UZI will do)
2) Give yourself weapon 31 (again, any non uzi weapon will do)
3) Get in a vehicle, and waste all of the uzi ammo
4) Leave your vehicle
5) Get in your vehicle again
6) You wont be in drive by mode locally, but you will remotly, so "pretend aim" (guess where the crosshair would be) at remote players and u will kill them.

p.s. i was v tired and ill when i wrote this.

Talidan

2007-11-12 15:07

administrator   ~~0006242

I think the server is using a getPlayerWeapon style check on the player to see if he has an uzi.

In reality, when a player runs out of ammo his gun is not removed - it still exists, but its ammo is 0. GTA just skips weapons that have 0 ammo when scrolling through weapons.

This would mean a weapon check would return that the player has the weapon (our lua getPlayerWeapon does so). A more reliable method would be to use getPlayerTotalAmmo, which returns 0 and is a better way to check if a player "doesnt have a gun".

Of course, this is all assumptions and the bug could be caused by something completely different.

Jax

2007-12-06 11:02

administrator   ~~0006617

Guns with 0 ammo should be removed now.

Issue History

Date Modified Username Field Change