View Issue Details

IDProjectCategoryView StatusLast Update
0002629Multi Theft Auto : San AndreasSynchronizationpublic2009-03-15 18:35
ReporterTalidanAssigned ToArc 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target Version1.0Fixed in Version1.0 
Summary0002629: First two or three bullets of walking weapons don't hit the target after reloading
Description

This affects specially the sawnoff shotguns, because they have a clip size of 2 bullets.

Tested with all walking guns and all running guns. This is totally confirmed.

TagsNo tags attached.

Relationships

related to 0003953 resolvedArc Projectiles don't sync correctly until player respawns once 
child of 0003714 closed Shooting Issues 

Activities

jbeta

2007-10-29 21:38

updater   ~~0006098

We noticed that sometimes, right before shooting, the arms quickly warp, pointing in a direction different from where the player's really aiming. The bullets probably go that way, not sure.

It was often seen when crouched.

Jax

2007-10-31 06:23

administrator   ~~0006105

Tested with lil_toady, worked fine for 10mins, then it was hard to even hit eachother.

ChrML

2007-11-02 18:55

administrator   ~~0006128

We need a way to reproduce this pretty reliably. I wasn't able to get this issue very much at all last test.

We tried: Aiming while remote player shoots and looking away from shooter.

ryden

2008-09-14 01:04

manager   ~~0008011

To reproduce get in front of the other player, shoot two bullets to the floor and while you are reloading fix your aim to the remote player. In the remote screen you will see all the time the remote player doing akimbo shoots.

ryden

2008-09-20 03:22

manager   ~~0008020

This is not the only problem. I will list them:

  • First of all, the well known problem of that you can't be carrying two sawnoffs.
  • It's not really that inaccurate. It's a problem of that bullets are only being created when you look away from the shooter.
  • Another important problem is that it's setting the remote player as doing akimbo when he reloads, making it aim somewhere else when it gets back to shooting you.
  • Other problem is that almost all the time remote players see you only shooting 1 bullet instead of the 2 that fit in the clip. This is because the ammo in clip and gun state are synced to those states (0 ammo, state 2 [reloading]) before it even has time to shoot the two bullets in the remote player.

Denver

2009-02-24 12:59

viewer   ~~0008416

We made the movie about sawn-off desynch. The thing, we have noticed, is that synch will become much better, if u are sitting. U can see that in the next movie: http://www.youtube.com/watch?v=LbMhiSwjfJM

Issue History

Date Modified Username Field Change