View Issue Details

IDProjectCategoryView StatusLast Update
0002615Multi Theft Auto : San AndreasScriptingpublic2007-10-23 12:05
ReportersinnergAssigned Tokevuwk 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002615: onVehicleDamage gets triggered with a negative loss
Description

When you fixVehicle a damaged car, and then you damage it again (drive into a wall), it will trigger onVehicleDamage with a negative loss.

Also, current event doesn't specify an attacker or attacking weapon (when valid, aka no 'driving' damage) + I think that is the reason why the attacker doesn't get credit for killing someone in a car (like throw a rocket at it)

TagsNo tags attached.

Activities

Talidan

2007-10-22 20:09

administrator   ~~0006050

About the attacker or no attacker weapon being specified - MTA doesnt sync those, it only syncs loss to save bandwidth.

sinnerg

2007-10-22 20:10

reporter   ~~0006051

It should be added for atleast vehicles who are occupied (for not-occupied vehicles you better leave it as is, since yeah, that could cause a traffic spike)

kevuwk

2007-10-23 12:05

administrator   ~~0006056

should be fixed tonight, don't think we can get an attacker for it but it deserves it's own report so create a new one

Issue History

Date Modified Username Field Change