View Issue Details

IDProjectCategoryView StatusLast Update
0002181Multi Theft Auto : San AndreasScriptingpublic2007-06-14 12:17
ReporterTalidanAssigned Tokevuwk 
PriorityimmediateSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002181: clientside call() returns lots of junk alongside real value
Description

Clientside call seems to return a lot of junk when used clientside. It does return the desired variable, but in random positions. The "junk" that fill up the rest are values that were originally entered in the call function.

E.g.1:

call(getResourceFromName("dropdownmenu"),"createDropDownMenu",80,300,200,20, 200,500, 0, false)

RESULT:
200, 500, 0, false, userdata: 0C9C4F18, 80, nil, nil, nil, userdata: 0C9C4F18

Here the desired value is the 5th value, and for some reason again at the 10th value. The rest all resemble args entered in the original function

E.g. 2

createDropDownMenu ( 0.05, 0.05, 0.95, 0.04, 0.95, 0.45, 0, true, theBrowser )

RESULT:
0.95, 0.45, 0, true, userdata: 09E7F450, 0.05, 0.05, nil, nil...

EDIT: On second thought, those userdata values may not be the desired return value, and could be other passed args. It looks like these return values are just a rearranged version of the args in call()

TagsNo tags attached.

Relationships

related to 0002190 closed call() skips nil arguments 

Activities

Cray

2007-06-13 05:18

viewer   ~~0004803

Can you provide an example of it working against a server call, and not working against a client call. It is almost identical code, so it is strange that it is working in one, but not the other.

jbeta

2007-06-14 11:15

updater   ~~0004821

Last edited: 2007-06-14 11:17

Bump for justice. Also:

Executing command:return call(getResourceFromName("calltest"),"testReturn")
Command executed! Result: 1, hello, userdata: 00459CB8

Executing client command:return call(getResourceFromName("calltest"),"testReturn")
Command executed! Result: table: 08BA19C8, function: 08BA19A8, table: 08BA19C8, function: 08BA19A8, table: 08BA19C8, function: 08BA19A8, table: 08BA19C8, function: 08BA19A8, table: 08BA19C8, function: 08BA19A8, table: 08BA19C8

Btw, in both cases it should return this:
return 1, "hello", nil, getRootElement()

Serverside call isn't returning nil between the string and the element either.

kevuwk

2007-06-14 12:16

administrator   ~~0004823

should return the relevant values

Issue History

Date Modified Username Field Change