View Issue Details

IDProjectCategoryView StatusLast Update
0002174Multi Theft Auto : San AndreasScriptingpublic2007-06-17 19:29
ReporterBrophYAssigned ToeAi 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionblue_sa.r2.a12 
Target VersionFixed in Versionmtasadm_v1.0-dp1 
Summary0002174: Downloading Resources doesnt get new files defined in meta.xml
Description

If you edit what files the resource should get in meta.xml, the resource still gets whatever was called before you changed it, i even tried 'refresh' in console, which had no effect

Before:
<meta>
<info author="BrophY" type="script" />
<script src="cars_client.lua" type="client" />
<file src="data/blistac.dff" />
<file src="data/blistac.txd" />
</meta>

After:
<meta>
<info author="BrophY" type="script" />
<script src="cars_client.lua" type="client" />
<file src="data/elegy.dff" />
<file src="data/elegy.txd" />
</meta>

But when i load the resource, it still gets the before info

TagsNo tags attached.

Activities

Talidan

2007-06-10 08:20

administrator   ~~0004782

this bug is very annoying

Jax

2007-06-10 09:00

administrator   ~~0004786

I dont think meta.xml gets reloaded atall, only the first time the resource is started

eAi

2007-06-16 19:27

administrator   ~~0004844

I can't reproduce this, despite trying very hard... :(

Cray

2007-06-16 23:57

viewer   ~~0004847

eAi, you added HasResourceChanged which CRC's all of the resources, including the meta and compares to the last one.

That method is called from within the load (which is called from refresh), so I think you fixed this without even knowing about it.

Cray

2007-06-16 23:58

viewer   ~~0004848

Closed as per the last note. Reopen with more details if it can be reproduced.

eAi

2007-06-17 19:29

administrator   ~~0004850

Yeah, I noticed I'd done that - I'm surprised I didn't do that when I first wrote the resource system... kinda odd...

Issue History

Date Modified Username Field Change